Option --enable does not work on commands

Bug #1588384 reported by Richard Theis on 2016-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-openstackclient
Fix Released
Critical
Richard Theis

Bug Description

As the following example illustrates, the --enable option on commands is ignored when the arguments are parsed. This appears to be related to the --enable-beta-commands option introduced by https://review.openstack.org/#/c/305436/

$ openstack router create --disable testrouter
+-------------------------+--------------------------------------+
| Field | Value |
+-------------------------+--------------------------------------+
| admin_state_up | DOWN |
| availability_zone_hints | |
| availability_zones | |
| description | |
| distributed | False |
| external_gateway_info | null |
| ha | False |
| headers | |
| id | b9dabe81-f159-4c88-a08c-53b4f5819089 |
| name | testrouter |
| project_id | 9aa6ffb67f3b4f148d56c69387ef70f5 |
| routes | |
| status | ACTIVE |
+-------------------------+--------------------------------------+
$ openstack router set --enable testrouter
Nothing specified to be set

Richard Theis (rtheis) on 2016-06-02
Changed in python-openstackclient:
assignee: nobody → Richard Theis (rtheis)
importance: Undecided → Critical
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/324609

Changed in python-openstackclient:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/324609
Committed: https://git.openstack.org/cgit/openstack/python-openstackclient/commit/?id=6f2c1734e3d66e261f231711455821321c1fc254
Submitter: Jenkins
Branch: master

commit 6f2c1734e3d66e261f231711455821321c1fc254
Author: Richard Theis <email address hidden>
Date: Thu Jun 2 09:53:55 2016 -0500

    Fix --enable options on commands

    The --enable option on commands is ignored when the arguments are parsed.
    This is related to the --enable-beta-commands option. Renaming the option
    to --os-beta-command fixes the problem.

    There's no need to handle backwards compatibility for the option name
    change because there hasn't been an OSC release yet with beta commands.

    Change-Id: I0327ba8a2058858a83e9a42e231470ed733cc834
    Closes-Bug: #1588384

Changed in python-openstackclient:
status: In Progress → Fix Released

This issue was fixed in the openstack/python-openstackclient 2.6.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers