Python OOPS wsgi adapter

TypeError: start_response() takes no keyword arguments

Reported by Haw Loeung on 2011-12-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-oops-wsgi
Critical
James Westby

Bug Description

[Mon Dec 12 07:04:09 2011] [error] [client xxx.xxx.xxx.xxx] mod_wsgi (pid=27658): Exception occurred processing WSGI script '/srv/lp-oops.canonical.com/cgi-bin/lpoops/bin/oopstools.wsgi'.
[Mon Dec 12 07:04:09 2011] [error] [client xxx.xxx.xxx.xxx] Traceback (most recent call last):
[Mon Dec 12 07:04:09 2011] [error] [client xxx.xxx.xxx.xxx] File "/srv/lp-oops.canonical.com/cgi-bin/lpoops/eggs/oops_wsgi-0.0.9-py2.6.egg/oops_wsgi/middleware.py", line 213, in oops_middleware
[Mon Dec 12 07:04:09 2011] [error] [client xxx.xxx.xxx.xxx] return [on_exception(exc_info)]
[Mon Dec 12 07:04:09 2011] [error] [client xxx.xxx.xxx.xxx] File "/srv/lp-oops.canonical.com/cgi-bin/lpoops/eggs/oops_wsgi-0.0.9-py2.6.egg/oops_wsgi/middleware.py", line 196, in on_exception
[Mon Dec 12 07:04:09 2011] [error] [client xxx.xxx.xxx.xxx] '500 Internal Server Error', headers, exc_info=exc_info)
[Mon Dec 12 07:04:09 2011] [error] [client xxx.xxx.xxx.xxx] TypeError: start_response() takes no keyword arguments

Related branches

Benji York (benji) on 2011-12-13
Changed in python-oops-tools:
status: New → Triaged
importance: Undecided → Critical
Robert Collins (lifeless) wrote :

This is caused by an outdated mod_wsgi which doesn't implement WSGI correctly.

James Westby (james-w) on 2012-01-25
affects: python-oops-tools → python-oops-wsgi
Changed in python-oops-wsgi:
assignee: nobody → James Westby (james-w)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers