.tox/functional/bin/python: can't open file '/usr/local/jenkins/slave_scripts/subunit2html.py': [Errno 2] No such file or directory

Bug #1491646 reported by Matt Riedemann on 2015-09-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Glance Client
Critical
Takashi NATSUME
python-cinderclient
Undecided
Matt Riedemann
python-heatclient
Fix Released
Undecided
Takashi NATSUME
python-keystoneclient
Critical
Matt Riedemann
python-manilaclient
Undecided
Matt Riedemann
python-neutronclient
Critical
Takashi NATSUME
python-novaclient
Critical
Matt Riedemann
Matt Riedemann (mriedem) on 2015-09-03
no longer affects: openstack-gate
Changed in python-novaclient:
status: New → In Progress
assignee: nobody → Matt Riedemann (mriedem)
Matt Riedemann (mriedem) on 2015-09-03
Changed in python-cinderclient:
status: New → Confirmed
Changed in python-keystoneclient:
status: New → Confirmed
Changed in python-manilaclient:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/219929

Changed in python-cinderclient:
assignee: nobody → Matt Riedemann (mriedem)
status: Confirmed → In Progress
Changed in python-keystoneclient:
assignee: nobody → Matt Riedemann (mriedem)
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/219931

Changed in python-manilaclient:
assignee: nobody → Matt Riedemann (mriedem)
status: Confirmed → In Progress
Matt Riedemann (mriedem) on 2015-09-03
Changed in python-novaclient:
importance: Undecided → Critical

Change abandoned by Matt Riedemann (<email address hidden>) on branch: master
Review: https://review.openstack.org/219924

Reviewed: https://review.openstack.org/219929
Committed: https://git.openstack.org/cgit/openstack/python-cinderclient/commit/?id=1c82825c4105f11c05f681e3dea16929f1a2efc5
Submitter: Jenkins
Branch: master

commit 1c82825c4105f11c05f681e3dea16929f1a2efc5
Author: Matt Riedemann <email address hidden>
Date: Wed Sep 2 17:18:28 2015 -0700

    Update path to subunit2html in post_test_hook

    Per:

    http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    The location of subunit2html changed on the images in the gate
    so update the path used in the post_test_hook.

    Long-term we should just use what's in devstack-gate.

    Change-Id: I5e50e7d7ad845aba26403df1df412c0a139a6dc7
    Closes-Bug: #1491646

Changed in python-cinderclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/219835
Committed: https://git.openstack.org/cgit/openstack/python-novaclient/commit/?id=eaf1e56b210c94e7d26ca99b5931f3688cef984c
Submitter: Jenkins
Branch: master

commit eaf1e56b210c94e7d26ca99b5931f3688cef984c
Author: Matt Riedemann <email address hidden>
Date: Wed Sep 2 17:05:46 2015 -0700

    Update path to subunit2html in post_test_hook

    Per:

    http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    The location of subunit2html changed on the images in the gate
    so update the path used in the post_test_hook.

    Long-term we should just use what's in devstack-gate.

    Change-Id: I5e50e7d7ad845aba26403df1df412c0a139a6dc7
    Closes-Bug: #1491646

    --------------
    squashed with:
    --------------

    Don't pass null device when attaching a volume

    The v2.1 API schema rejects null device values in an
    os-volume_attachments request, so only include the device in the request
    if one is specified on the command line.

    Closes-Bug: #1491325

    Change-Id: I4fa4019f19f9af6ff350db2fb6e524fa8570a6f3

Changed in python-novaclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/219931
Committed: https://git.openstack.org/cgit/openstack/python-keystoneclient/commit/?id=3e862bbb1e2a7b488cf2de43651270e6afbb82ad
Submitter: Jenkins
Branch: master

commit 3e862bbb1e2a7b488cf2de43651270e6afbb82ad
Author: Matt Riedemann <email address hidden>
Date: Wed Sep 2 17:20:17 2015 -0700

    Update path to subunit2html in post_test_hook

    Per:

    http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    The location of subunit2html changed on the images in the gate
    so update the path used in the post_test_hook.

    Long-term we should just use what's in devstack-gate.

    Change-Id: I5e50e7d7ad845aba26403df1df412c0a139a6dc7
    Closes-Bug: #1491646

Changed in python-keystoneclient:
status: In Progress → Fix Committed
Changed in python-glanceclient:
assignee: nobody → Takashi NATSUME (natsume-takashi)
Changed in python-neutronclient:
assignee: nobody → Takashi NATSUME (natsume-takashi)

Fix proposed to branch: master
Review: https://review.openstack.org/220372

Changed in python-glanceclient:
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/220380

Changed in python-neutronclient:
status: New → In Progress
Changed in python-neutronclient:
importance: Undecided → Critical
Changed in python-heatclient:
assignee: nobody → Takashi NATSUME (natsume-takashi)
Changed in python-novaclient:
milestone: none → 2.28.0
status: Fix Committed → Fix Released

Fix proposed to branch: master
Review: https://review.openstack.org/220383

Changed in python-heatclient:
status: New → In Progress

Reviewed: https://review.openstack.org/220380
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=d75f79f67c176a38d41fcc5f8794d5956ac65ace
Submitter: Jenkins
Branch: master

commit d75f79f67c176a38d41fcc5f8794d5956ac65ace
Author: Takashi NATSUME <email address hidden>
Date: Fri Sep 4 11:04:04 2015 +0900

    Update path to subunit2html in post_test_hook

    Per:

    http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    The location of subunit2html changed on the images in the gate
    so update the path used in the post_test_hook.

    Long-term we should just use what's in devstack-gate.

    Change-Id: If37743547f739e494501bbc5dc3bb214293919fa
    Closes-Bug: #1491646

Changed in python-neutronclient:
status: In Progress → Fix Committed
Changed in python-glanceclient:
importance: Undecided → Critical

Reviewed: https://review.openstack.org/220372
Committed: https://git.openstack.org/cgit/openstack/python-glanceclient/commit/?id=90b7dc4141d18445ea40d7b6b4c3d25a2c163284
Submitter: Jenkins
Branch: master

commit 90b7dc4141d18445ea40d7b6b4c3d25a2c163284
Author: Takashi NATSUME <email address hidden>
Date: Fri Sep 4 09:28:06 2015 +0900

    Update path to subunit2html in post_test_hook

    Per:

    http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    The location of subunit2html changed on the images in the gate
    so update the path used in the post_test_hook.

    Long-term we should just use what's in devstack-gate.

    Change-Id: I142b3c0590ba2fa880973b0ee306ebd1db27fd03
    Closes-Bug: #1491646

Changed in python-glanceclient:
status: In Progress → Fix Committed
Changed in python-keystoneclient:
milestone: none → 1.7.0
status: Fix Committed → Fix Released

Change abandoned by Takashi NATSUME (<email address hidden>) on branch: master
Review: https://review.openstack.org/220383

Changed in python-neutronclient:
milestone: none → 3.0.0
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/220853
Committed: https://git.openstack.org/cgit/openstack/python-heatclient/commit/?id=4804dce0b4e73c4a6dfc9e46542f209e8c71f845
Submitter: Jenkins
Branch: master

commit 4804dce0b4e73c4a6dfc9e46542f209e8c71f845
Author: Takashi NATSUME <email address hidden>
Date: Tue Sep 8 16:09:19 2015 +0900

    Modify test templates and the path to subunit2html

    This patch contains the following two fixes
    because the gate job fails if they are not applied
    at the same time.

    1) Use OS::Heat::TestResource in test templates

    Use OS::Heat::TestResource instead of OS::Nova::Server
    in heat_minimal.yaml and heat_minimal_hot.yaml

    2) Update path to subunit2html in post_test_hook

    Per:

    http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    The location of subunit2html changed on the images in the gate
    so update the path used in the post_test_hook.

    Long-term we should just use what's in devstack-gate.

    Change-Id: I67acc3145719c3de1199e36c6667d975652d262f
    Closes-Bug: #1492115
    Closes-Bug: #1491646

Changed in python-heatclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/219934
Committed: https://git.openstack.org/cgit/openstack/python-manilaclient/commit/?id=2c334f03dce0bbc7e05eba14e7e195dc06fc5c7e
Submitter: Jenkins
Branch: master

commit 2c334f03dce0bbc7e05eba14e7e195dc06fc5c7e
Author: Matt Riedemann <email address hidden>
Date: Wed Sep 2 17:23:07 2015 -0700

    Update path to subunit2html in post_test_hook

    Per:

    http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    The location of subunit2html changed on the images in the gate
    so update the path used in the post_test_hook.

    Long-term we should just use what's in devstack-gate.
    Change-Id: I5e50e7d7ad845aba26403df1df412c0a139a6dc7
    Closes-Bug: #1491646

Changed in python-manilaclient:
status: In Progress → Fix Committed
Changed in python-cinderclient:
milestone: none → 1.4.0
status: Fix Committed → Fix Released
Dolph Mathews (dolph) on 2015-09-12
Changed in python-keystoneclient:
importance: Undecided → Critical
Changed in python-heatclient:
milestone: none → 0.8.0
Changed in python-glanceclient:
milestone: none → 1.1.0
status: Fix Committed → Fix Released
Changed in python-manilaclient:
milestone: none → 1.3.0
status: Fix Committed → Fix Released
Changed in python-heatclient:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/224932
Committed: https://git.openstack.org/cgit/openstack/python-keystoneclient/commit/?id=8d66e529cfab926c98d569ee83e5aeef76f05776
Submitter: Jenkins
Branch: stable/kilo

commit 8d66e529cfab926c98d569ee83e5aeef76f05776
Author: Matt Riedemann <email address hidden>
Date: Wed Sep 2 17:20:17 2015 -0700

    Update path to subunit2html in post_test_hook

    Per:

    http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    The location of subunit2html changed on the images in the gate
    so update the path used in the post_test_hook.

    Long-term we should just use what's in devstack-gate.

    Change-Id: I5e50e7d7ad845aba26403df1df412c0a139a6dc7
    Closes-Bug: #1491646
    (cherry picked from commit 3e862bbb1e2a7b488cf2de43651270e6afbb82ad)

tags: added: in-stable-kilo

Reviewed: https://review.openstack.org/231797
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=9c34bd21cf0f6587ea956218b1133e485c8a0562
Submitter: Jenkins
Branch: stable/kilo

commit 9c34bd21cf0f6587ea956218b1133e485c8a0562
Author: Takashi NATSUME <email address hidden>
Date: Fri Sep 4 11:04:04 2015 +0900

    Update path to subunit2html in post_test_hook

    Per:

    http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    The location of subunit2html changed on the images in the gate
    so update the path used in the post_test_hook.

    Long-term we should just use what's in devstack-gate.

    Closes-Bug: #1491646
    (cherry picked from commit d75f79f67c176a38d41fcc5f8794d5956ac65ace)

    This also adds a gate_hook to invoke d-g for env prepping. It merely
    triggers main devstack-gate script. We need the hook because our new
    neutronclient jobs define gate_hook function that points to it, and in
    that case devstack-gate does NOT trigger its main script, leaving it up
    to the hook.

    Depends-on: I8549db52fa5b752202ac7f019b3e1931a697e337
    Change-Id: If37743547f739e494501bbc5dc3bb214293919fa

Change abandoned by Steve Martinelli (<email address hidden>) on branch: feature/keystoneauth_integration
Review: https://review.openstack.org/218269
Reason: need to abandon in order to delete branch

Reviewed: https://review.openstack.org/245621
Committed: https://git.openstack.org/cgit/openstack/python-novaclient/commit/?id=b1b51a6ac42bc4cc63ab326c04fb4b6f4ad36ac7
Submitter: Jenkins
Branch: stable/kilo

commit b1b51a6ac42bc4cc63ab326c04fb4b6f4ad36ac7
Author: Tony Breeds <email address hidden>
Date: Mon Nov 16 14:00:09 2015 +1100

    subunit2html has moved.

    As per: http://lists.openstack.org/pipermail/openstack-dev/2015-August/072982.html

    call subunit2html from it's new path.

    Related-Bug: 1491646
    Change-Id: I661c55c5b6bc0ef6a6f102f4178b561dcac4883f

This issue was fixed in the openstack/python-cinderclient 1.4.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers