gigabytes and volumes still present in nova command line client

Bug #1078089 reported by Davanum Srinivas (DIMS) on 2012-11-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
python-novaclient
High
Nikola Đipanov

Bug Description

trying latest devstack, i can see quotas for volumes and gigabytes as shown below. these were removed as part of https://blueprints.launchpad.net/nova/+spec/delete-nova-volume (very specifically the gerritt review https://review.openstack.org/#/c/15602/).

Note that os-quota-sets API changed as a result as well, we can no longer get/set gigabytes and gigabytes using that API

root@dims-desktop:/# nova quota-defaults demo
+-----------------------------+-------+
| Property | Value |
+-----------------------------+-------+
| cores | 20 |
| floating_ips | 10 |
| gigabytes | None |
| injected_file_content_bytes | 10240 |
| injected_files | 5 |
| instances | 10 |
| metadata_items | 128 |
| ram | 51200 |
| volumes | None |
+-----------------------------+-------+
root@dims-desktop:/# nova quota-show demo
+-----------------------------+-------+
| Property | Value |
+-----------------------------+-------+
| cores | 20 |
| floating_ips | 10 |
| gigabytes | None |
| injected_file_content_bytes | 10240 |
| injected_files | 5 |
| instances | 10 |
| metadata_items | 128 |
| ram | 51200 |
| volumes | None |
+-----------------------------+-------+
root@dims-desktop:/# nova quota-update
usage: nova quota-update [--instances <instances>] [--cores <cores>]
                         [--ram <ram>] [--volumes <volumes>]
                         [--gigabytes <gigabytes>]
                         [--floating-ips <floating-ips>]
                         [--metadata-items <metadata-items>]
                         [--injected-files <injected-files>]
                         [--injected-file-content-bytes <injected-file-content-bytes>]
                         <tenant-id>
error: too few arguments
Try 'nova help quota-update' for more information.

quick browse of python client code shows that it still has support for volumes and gigabytes:
https://github.com/openstack/python-novaclient/blob/master/novaclient/v1_1/quotas.py

Looks like maxTotalVolumeGigabytes and maxTotalVolumes are AWOL from "v2/{tenant_id}/limits" as well

# curl -i http://127.0.0.1:8774/v2/cf4b48af92974d0c803d3e3eba706728/limits -X GET -H "X-Auth-Project-Id: demo" -H "User-Agent: python-novaclient" -H "Accept: application/json" -H "X-Auth-Token: bbf73c9dea0b4354baea5bc6e7f73da3"
HTTP/1.1 200 OK
X-Compute-Request-Id: req-d9ef5e32-a2ed-42d9-8f76-5f3a5eb6f0fa
Content-Type: application/json
Content-Length: 1126
Date: Mon, 12 Nov 2012 21:31:43 GMT

{"limits": {"rate": [{"regex": ".*", "limit": [{"next-available": "2012-11-12T21:31:42Z", "unit": "MINUTE", "verb": "POST", "remaining": 10, "value": 10}, {"next-available": "2012-11-12T20:55:44Z", "unit": "MINUTE", "verb": "PUT", "remaining": 9, "value": 10}, {"next-available": "2012-11-12T21:31:42Z", "unit": "MINUTE", "verb": "DELETE", "remaining": 100, "value": 100}], "uri": "*"}, {"regex": "^/servers", "limit": [{"next-available": "2012-11-12T21:31:42Z", "unit": "DAY", "verb": "POST", "remaining": 50, "value": 50}], "uri": "*/servers"}, {"regex": ".*changes-since.*", "limit": [{"next-available": "2012-11-12T21:31:42Z", "unit": "MINUTE", "verb": "GET", "remaining": 3, "value": 3}], "uri": "*changes-since*"}], "absolute": {"maxServerMeta": 128, "maxPersonality": 5, "maxImageMeta": 128, "maxPersonalitySize": 10240, "maxSecurityGroupRules": 20, "maxTotalKeypairs": 100, "totalRAMUsed": 0, "totalInstancesUsed": 0, "maxSecurityGroups": 10, "maxTotalCores": 20, "totalSecurityGroupsUsed": 0, "maxTotalFloatingIps": 10, "totalKeyPairsUsed": 0, "maxTotalInstances": 10, "totalCoresUsed": 0, "maxTotalRAMSize": 51200}}}

are we not supporting those 2 quota's any more?

Sean Dague (sdague) on 2012-11-12
Changed in python-novaclient:
status: New → Confirmed
Changed in nova:
status: New → Confirmed
importance: Undecided → High
Changed in python-novaclient:
importance: Undecided → High
Joe Gordon (jogo) wrote :

That is correct, those two quotas were for volumes, and nova does not support volumes any more. (Code was deprecated in Folsom)

Changed in python-novaclient:
assignee: nobody → Joe Gordon (joe-gordon0)
no longer affects: nova

Fix proposed to branch: master
Review: https://review.openstack.org/16016

Changed in python-novaclient:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/16289

Changed in python-novaclient:
assignee: Joe Gordon (joe-gordon0) → Nikola Đipanov (ndipanov)
Attila Fazekas (afazekas) wrote :

I wonder I should be able to manage Security Group Quota here ?

Reviewed: https://review.openstack.org/16289
Committed: http://github.com/openstack/python-novaclient/commit/47355b741b50a63227fb38e6be6b485902efe3e5
Submitter: Jenkins
Branch: master

commit 47355b741b50a63227fb38e6be6b485902efe3e5
Author: Nikola Dipanov <email address hidden>
Date: Fri Nov 16 10:00:46 2012 +0100

    Improved quota output

    This patch makes the output of quota show a bit more informative
    by not setting a simple None to a non-existing quota, but not showing it
    all together.

    Kind of fixes bug #1078906
    and also bug #1078089

    Change-Id: Ic42837d218a80f37e0c6d56625c9804d076f444c

Changed in python-novaclient:
status: In Progress → Fix Committed
Changed in python-novaclient:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers