Remove mox/mox3 usage from testing

Bug #1753504 reported by Akihiro Motoki on 2018-03-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Neutron FWaaS dashboard
High
Akihiro Motoki
Neutron VPNaaS dashboard
High
Akihiro Motoki
networking-midonet
High
Akihiro Motoki
networking-vsphere
Undecided
Unassigned
python-neutronclient
High
Hongbin Lu

Bug Description

<<< mox-removal community goal in Rocky release has been completed >>>

This bug is used to track the "removal mox/mox3 usage from testing" community goal in Rocky [1][3] under the neutron stadium [2].

As of Mar 5 2018, the following projects are using mox3.

- python-neutronclient (hongbin.lu): DONE
- networking-midonet (amtoki): DONE
- neutron-fwaas-dashboard (amotoki): DONE
- neutron-vpnaas-dashboard (amotoki) DONE

We need assignees for individual projects.
amotoki can help in reviews and advises.

[1] https://governance.openstack.org/tc/goals/rocky/mox_removal.html
[2] https://governance.openstack.org/tc/reference/projects/neutron.html
[3] https://storyboard.openstack.org/#!/story/2001546

Akihiro Motoki (amotoki) on 2018-03-05
Changed in neutron-fwaas-dashboard:
importance: Undecided → High
Changed in neutron-vpnaas-dashboard:
importance: Undecided → High
assignee: nobody → Akihiro Motoki (amotoki)
Changed in neutron-vpnaas-dashboard:
status: New → In Progress
Akihiro Motoki (amotoki) on 2018-03-05
description: updated
Hongbin Lu (hongbin.lu) on 2018-03-05
Changed in python-neutronclient:
assignee: nobody → Hongbin Lu (hongbin.lu)

Fix proposed to branch: master
Review: https://review.openstack.org/550641

Changed in python-neutronclient:
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/550647

Fix proposed to branch: master
Review: https://review.openstack.org/550986

Fix proposed to branch: master
Review: https://review.openstack.org/551000

Fix proposed to branch: master
Review: https://review.openstack.org/551037

Fix proposed to branch: master
Review: https://review.openstack.org/551720

Changed in neutron-fwaas-dashboard:
assignee: nobody → Akihiro Motoki (amotoki)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/551721

Fix proposed to branch: master
Review: https://review.openstack.org/551722

Fix proposed to branch: master
Review: https://review.openstack.org/551723

Fix proposed to branch: master
Review: https://review.openstack.org/551724

Changed in networking-midonet:
status: New → Confirmed
importance: Undecided → High

Reviewed: https://review.openstack.org/550641
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=03c5c1f537bdb31f1014721d0c07660b8c74f75b
Submitter: Zuul
Branch: master

commit 03c5c1f537bdb31f1014721d0c07660b8c74f75b
Author: Hongbin Lu <email address hidden>
Date: Wed Mar 7 23:02:59 2018 +0000

    Remove mox/mox3 usage from test_quota

    Change-Id: I879a3ae40d13e0a41b655ee028640463aa809c8b
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/550647
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=06961da731611fa813e8e4c6cd63a660d17d68d2
Submitter: Zuul
Branch: master

commit 06961da731611fa813e8e4c6cd63a660d17d68d2
Author: Hongbin Lu <email address hidden>
Date: Wed Mar 7 23:45:29 2018 +0000

    Remove mox/mox3 usage from test_cli20_tag

    Change-Id: I2570d45b155d968c6711a10012cd38619e83e4a2
    Partial-Bug: #1753504

Fix proposed to branch: master
Review: https://review.openstack.org/553573

Fix proposed to branch: master
Review: https://review.openstack.org/553609

Reviewed: https://review.openstack.org/550986
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=f2abd8ce1645984ab5a2f5f267527fb3b386814b
Submitter: Zuul
Branch: master

commit f2abd8ce1645984ab5a2f5f267527fb3b386814b
Author: Hongbin Lu <email address hidden>
Date: Thu Mar 8 19:40:32 2018 +0000

    Remove mox/mox3 usage from test_cli20_port.py

    Change-Id: I0ea56965b0753b56bd51ddace0f180723ac6c432
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/551000
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=d8a605c591e3fcd049925d1911d7314965739d0c
Submitter: Zuul
Branch: master

commit d8a605c591e3fcd049925d1911d7314965739d0c
Author: Hongbin Lu <email address hidden>
Date: Thu Mar 8 20:48:02 2018 +0000

    Remove mox/mox3 usage from test_name_or_id.py

    Change-Id: Iefaeb45312177be172858203715bdc1db88e6add
    Partial-Bug: #1753504

Fix proposed to branch: master
Review: https://review.openstack.org/553872

Fix proposed to branch: master
Review: https://review.openstack.org/553877

Fix proposed to branch: master
Review: https://review.openstack.org/553878

Fix proposed to branch: master
Review: https://review.openstack.org/553883

Reviewed: https://review.openstack.org/551037
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=c50b1267710fdc0585a8618c6f9513bd0f3a6161
Submitter: Zuul
Branch: master

commit c50b1267710fdc0585a8618c6f9513bd0f3a6161
Author: Hongbin Lu <email address hidden>
Date: Fri Mar 9 00:16:46 2018 +0000

    Remove mox/mox3 usage from test_cli20_network.py

    Change-Id: I3c9f53e57ef7fc38b0d4b2eb3138902004cff2b3
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/553540
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=93e4ef2e7de95aa16e13331df14b2d157c9a24a5
Submitter: Zuul
Branch: master

commit 93e4ef2e7de95aa16e13331df14b2d157c9a24a5
Author: Hongbin Lu <email address hidden>
Date: Thu Mar 15 17:58:49 2018 +0000

    Remove mox/mox3 usage from test_cli20_subnetpool.py

    Change-Id: I26e15e051a9754f61d9ba04a59f62bc979e52fb1
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/553573
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=02b6e6f841dcc262fb42e88d5ead06025edb0190
Submitter: Zuul
Branch: master

commit 02b6e6f841dcc262fb42e88d5ead06025edb0190
Author: Hongbin Lu <email address hidden>
Date: Thu Mar 15 18:16:21 2018 +0000

    Remove mox/mox3 usage from test_cli20_subnet.py

    Change-Id: I783260f6853a7ba6f911f718ce759b292595da4f
    Partial-Bug: #1753504

Fix proposed to branch: master
Review: https://review.openstack.org/555477

Changed in neutron-fwaas-dashboard:
assignee: Akihiro Motoki (amotoki) → Yushiro FURUKAWA (y-furukawa-2)
Changed in python-neutronclient:
assignee: Hongbin Lu (hongbin.lu) → Slawek Kaplonski (slaweq)

Reviewed: https://review.openstack.org/553609
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=5a0d8c8b907f4ebbe5a1d7f8b0704ecdd7170a54
Submitter: Zuul
Branch: master

commit 5a0d8c8b907f4ebbe5a1d7f8b0704ecdd7170a54
Author: Hongbin Lu <email address hidden>
Date: Thu Mar 15 20:44:13 2018 +0000

    Remove mox/mox3 usage from test_cli20_securitygroup.py

    Change-Id: I7d15d42ffd0cd94972809569633d6f4a38c60d4b
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/553871
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=bcce41e8478e92c0b9b60c2dd91b826d687264ef
Submitter: Zuul
Branch: master

commit bcce41e8478e92c0b9b60c2dd91b826d687264ef
Author: Hongbin Lu <email address hidden>
Date: Fri Mar 16 18:01:29 2018 +0000

    Remove mox/mox3 from test_cli20_agentschedulers.py

    Change-Id: If1b9a9d1d16bed7c28b87bd47c30d5aaa05da546
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/553872
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=633a20cde9a282f17b59d120f5c97e3989e6cec1
Submitter: Zuul
Branch: master

commit 633a20cde9a282f17b59d120f5c97e3989e6cec1
Author: Hongbin Lu <email address hidden>
Date: Fri Mar 16 18:12:15 2018 +0000

    Remove mox/mox3 from test_cli20_address_scope.py

    Change-Id: Ibba1061d447a73bb3e13e1b8869300d2c0de1b16
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/553877
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=8dac1afd43481d9c9ffcde3674eed3f7c64896ab
Submitter: Zuul
Branch: master

commit 8dac1afd43481d9c9ffcde3674eed3f7c64896ab
Author: Hongbin Lu <email address hidden>
Date: Fri Mar 16 18:34:07 2018 +0000

    Remove mox/mox3 usage from bgp

    Change-Id: Ie07cf987382281c00023b41ce74c314ec2457502
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/553878
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=260f74308e3c78d3e1561280578f03cb5612ff4f
Submitter: Zuul
Branch: master

commit 260f74308e3c78d3e1561280578f03cb5612ff4f
Author: Hongbin Lu <email address hidden>
Date: Fri Mar 16 18:42:40 2018 +0000

    Remove mox/mox3 usage from fw modules

    Change-Id: I913993c0bff15df19bf3978ed36062f970eef538
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/553883
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=ce623030ee19619eb28276e6f9f0a395261560ba
Submitter: Zuul
Branch: master

commit ce623030ee19619eb28276e6f9f0a395261560ba
Author: Hongbin Lu <email address hidden>
Date: Fri Mar 16 19:26:18 2018 +0000

    Remove mox/mox3 usage from lb modules

    Change-Id: I667dd870b615d4a9ccefd35fcb1ebf15760b1d6d
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/549651
Committed: https://git.openstack.org/cgit/openstack/neutron-vpnaas-dashboard/commit/?id=0087e89e444bcb8bd3961c889d046fe1295841f0
Submitter: Zuul
Branch: master

commit 0087e89e444bcb8bd3961c889d046fe1295841f0
Author: Akihiro Motoki <email address hidden>
Date: Mon Mar 5 08:11:43 2018 +0900

    Drop mox usage from VPNaaS API tests

    This is part of mox-removal community goal in Rocky.

    Partial-Bug: #1753504
    Change-Id: I95ec86d8da0293e3d2be27d4b147e648a5bfbdc0

Reviewed: https://review.openstack.org/549652
Committed: https://git.openstack.org/cgit/openstack/neutron-vpnaas-dashboard/commit/?id=6cbdee8340734962912657057875a91a0f3214ae
Submitter: Zuul
Branch: master

commit 6cbdee8340734962912657057875a91a0f3214ae
Author: Akihiro Motoki <email address hidden>
Date: Mon Mar 5 08:12:47 2018 +0900

    Drop mox usage from VPNaaS panel tests

    AddEndpointGroup workflow previously passes 'subnets' and 'cidrs'
    in "context" data to endpointgroup_create(), but precisely speaking
    this is not correct (even though endpointgroup_create() does filtering
    inside the function). After mock introduction, arguments are checked
    more stricly and it is tricky to have 'subnets' and 'cidrs' in
    assert_called_once_with, so this commit changes the arguments in
    the AddEndpointGroup workflow.

    This is part of mox-removal community goal in Rocky.

    Partial-Bug: #1753504
    Change-Id: Ida3a5fdad267144392aba946c089113c478c4405

Reviewed: https://review.openstack.org/549774
Committed: https://git.openstack.org/cgit/openstack/neutron-vpnaas-dashboard/commit/?id=4ae1508604a00df70b57d331c4f56d4069711cac
Submitter: Zuul
Branch: master

commit 4ae1508604a00df70b57d331c4f56d4069711cac
Author: Akihiro Motoki <email address hidden>
Date: Mon Mar 5 23:21:48 2018 +0900

    Drop mox3 from test-requirements.txt

    create_stubs in test.helpers is also dropped in this commit
    because this creates a stub using mox.

    This is part of mox-removal community goal in Rocky.

    Depends-On: https://review.openstack.org/549842/
    Change-Id: I150d654b40dd14bb738e0da991e5db7f311cf7b6
    Closes-Bug: #1753504

Changed in neutron-vpnaas-dashboard:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/555469
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=f6b1e85899acd20f8a08a8302542497f2b4977ae
Submitter: Zuul
Branch: master

commit f6b1e85899acd20f8a08a8302542497f2b4977ae
Author: Hongbin Lu <email address hidden>
Date: Thu Mar 22 21:52:29 2018 +0000

    Remove mox/mox3 usage from test_cli20.py

    Change-Id: Ib4dc5f6c7ba57d94364f19a049c690d3817c723a
    Partial-Bug: #1753504

Reviewed: https://review.openstack.org/555477
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=ac24ab19c3a5ab71036c6f5447a904d022dec73c
Submitter: Zuul
Branch: master

commit ac24ab19c3a5ab71036c6f5447a904d022dec73c
Author: Hongbin Lu <email address hidden>
Date: Thu Mar 22 22:05:03 2018 +0000

    Remove mox3 from test-requirements.txt

    Change-Id: I9719d9b308811e7bf218af2f7da949b6c0509fc1
    Closes-Bug: #1753504

Changed in python-neutronclient:
status: In Progress → Fix Released
Changed in neutron-fwaas-dashboard:
assignee: Yushiro FURUKAWA (y-furukawa-2) → Akihiro Motoki (amotoki)
Hongbin Lu (hongbin.lu) on 2018-03-27
Changed in python-neutronclient:
assignee: Slawek Kaplonski (slaweq) → Hongbin Lu (hongbin.lu)
description: updated
Akihiro Motoki (amotoki) on 2018-03-27
description: updated

Reviewed: https://review.openstack.org/551720
Committed: https://git.openstack.org/cgit/openstack/neutron-fwaas-dashboard/commit/?id=8825c3cd5c753e85524654b5be5645a8f45f314d
Submitter: Zuul
Branch: master

commit 8825c3cd5c753e85524654b5be5645a8f45f314d
Author: Akihiro Motoki <email address hidden>
Date: Sun Mar 11 09:28:26 2018 +0900

    Drop mox usage from FWaaS v1 API tests

    This is part of mox-removal community goal in Rocky.

    Change-Id: If2d53576e1ea9fa888df822b760beacf1cef074a
    Depends-On: https://review.openstack.org/#/c/556785/
    Partial-Bug: #1753504

Changed in neutron-fwaas-dashboard:
assignee: Akihiro Motoki (amotoki) → Yushiro FURUKAWA (y-furukawa-2)

Reviewed: https://review.openstack.org/551721
Committed: https://git.openstack.org/cgit/openstack/neutron-fwaas-dashboard/commit/?id=b17392b5fa37a4bed1159d86f06f07e451aab41d
Submitter: Zuul
Branch: master

commit b17392b5fa37a4bed1159d86f06f07e451aab41d
Author: Akihiro Motoki <email address hidden>
Date: Sun Mar 11 09:28:33 2018 +0900

    Drop mox usage from FWaaS v1 panel tests

    Note that test_add_firewall_post_with_router_extension() is also fixed
    because we need to post unassociated router IDs to the form of creating
    a new firewall but the previous test sends associated router ID.
    This fix is required to pass the test after mock is used.
    I am not sure why the test succeeded with mox though....

    Also cleans up unnecessary mocked methods.

    This is part of mox-removal community goal in Rocky.
    Partial-Bug: #1753504

    Change-Id: I033421aeb00d97c049bec3d04da6989c811d1514

Reviewed: https://review.openstack.org/551722
Committed: https://git.openstack.org/cgit/openstack/neutron-fwaas-dashboard/commit/?id=58804c1e994155b570b61ddaf81237a8ce37c483
Submitter: Zuul
Branch: master

commit 58804c1e994155b570b61ddaf81237a8ce37c483
Author: Akihiro Motoki <email address hidden>
Date: Sun Mar 11 09:28:37 2018 +0900

    Drop mox usage from FWaaS v2 API tests

    This is part of mox-removal community goal in Rocky.
    Partial-Bug: #1753504

    Change-Id: I41362bb41384434418f1250e7a97eb1226202c51

Reviewed: https://review.openstack.org/551723
Committed: https://git.openstack.org/cgit/openstack/neutron-fwaas-dashboard/commit/?id=6cd9d487ed9dba893a8946a24c221312dde01b03
Submitter: Zuul
Branch: master

commit 6cd9d487ed9dba893a8946a24c221312dde01b03
Author: Akihiro Motoki <email address hidden>
Date: Sun Mar 11 09:28:40 2018 +0900

    Drop mox usage from FWaaS v2 panel tests

    Previously expected PUT data for update tests were completely wrong.
    I don't know why the previous mox unit tests pass. After switching to
    mock, they no longer can pass and this commit fixes them.

    This patch also clean up unnecessary mocked methods.

    This is part of mox-removal community goal in Rocky.
    Partial-Bug: #1753504

    Change-Id: I135b1745c933deca37d17e6af250e16aabf912e7

Changed in neutron-fwaas-dashboard:
assignee: Yushiro FURUKAWA (y-furukawa-2) → Akihiro Motoki (amotoki)

Reviewed: https://review.openstack.org/551724
Committed: https://git.openstack.org/cgit/openstack/neutron-fwaas-dashboard/commit/?id=6faaf2cad7a77ff830c632848009c6aa035ada2a
Submitter: Zuul
Branch: master

commit 6faaf2cad7a77ff830c632848009c6aa035ada2a
Author: Akihiro Motoki <email address hidden>
Date: Sun Mar 11 09:30:10 2018 +0900

    Drop mox3 from test-requirements.txt

    create_stubs in test.helpers is also dropped in this commit
    because this creates a stub using mox.

    This is part of mox-removal community goal in Rocky.

    lower-constraints.txt are updated to pass requirements-check
    as this file is updated automatically now and we need to update
    it when updating this file from some reasons.

    Change-Id: Ib4c7c3003ce5d895c9c514aa0af6491da1667891
    Closes-Bug: #1753504

Changed in neutron-fwaas-dashboard:
status: In Progress → Fix Released
Akihiro Motoki (amotoki) wrote :

The remaining project with mox3 is now networking-midonet. We need a new release for python-neutronclient so that networking-midonet test consumes a new testing interface from python-neutronclient.

This issue was fixed in the openstack/python-neutronclient 6.8.0 release.

The 'networking-vSphere' project is also affected by this 'mox/mox3' change.

Changed in networking-vsphere:
status: New → Confirmed

Reviewed: https://review.openstack.org/558621
Committed: https://git.openstack.org/cgit/openstack/networking-midonet/commit/?id=e93a57d5323464f3f2e5660e606ab92f5ea2b77a
Submitter: Zuul
Branch: master

commit e93a57d5323464f3f2e5660e606ab92f5ea2b77a
Author: Akihiro Motoki <email address hidden>
Date: Wed Apr 4 05:10:05 2018 +0900

    Remove mox/mox3 usage

    Surprisingly networking-midonet does not include mox3 in
    test-requirements.txt. I haven't checked who is responsible
    to install mox3, but at least this patch makes networking-midonet
    mox-free.

    ----------------------------------------
    This commit includes the following unrelated change to pass the gate.

    Disable failing style checks (W503, E402) for now.
    I (yamamoto) guess they are new with pycodestyle 2.4.0.

    Related-Bug: #1762795
    ----------------------------------------

    Closes-Bug: #1753504
    Depends-On: https://review.openstack.org/#/c/558644/
    Change-Id: I4293d64079c37d21bcd67908d28aa8673fcc5369

Changed in networking-midonet:
status: Confirmed → Fix Released

Patch submitted for networking-vsphere repo.
https://review.openstack.org/#/c/560165/

Reviewed: https://review.openstack.org/560165
Committed: https://git.openstack.org/cgit/openstack/networking-vsphere/commit/?id=424629c8330d737cb5f479308c6e7f34d711c1e5
Submitter: Zuul
Branch: master

commit 424629c8330d737cb5f479308c6e7f34d711c1e5
Author: Stephen Ma <email address hidden>
Date: Tue Apr 10 12:38:44 2018 -0700

    Replace mox with mock in the ovsvapp unit tests

    Partial-Bug: #1753504

    Change-Id: Ia0d5a4e754af5391716fb4663c162c6e6ae67b72

Akihiro Motoki (amotoki) wrote :

This bug is used to track official projects under the neutron governance. We have completed the mox-removal community goal as "neutron" project.

If you need to track mox-removal progress in network related projects, please file a separate bug.

description: updated
description: updated

This issue was fixed in the openstack/networking-midonet 7.0.0.0b1 development milestone.

Changed in networking-midonet:
assignee: nobody → Akihiro Motoki (amotoki)
milestone: none → 7.0.0

This issue was fixed in the openstack/neutron-vpnaas-dashboard 1.3.0 release.

This issue was fixed in the openstack/neutron-fwaas-dashboard 1.4.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers