Output from v6 of python-mode different from v5

Bug #990079 reported by Rick Muller on 2012-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-mode.el
Medium
Andreas Roehler

Bug Description

In python-mode v5, when I executed py-execute-buffer on a python script I would get a split window, viewing a buffer called *Python Output*, that had only the output from executing the script, hello world, or whatever.

In python-mode v6, when I execute the same script, I get split window with a buffer that has a running python shell, with the output

Python 2.7.3 (default, Apr 19 2012, 00:55:09)
[GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
## executing temporary file /var/folders/71/3g808qx93s5_lv0kgpkzy5z80000gp/T/Python25335pPA.py...
>>> Hello, world

The problem is that the v5 behavior is much more convenient, and I've gotten used to running scripts this way. Is there any way to set the behavior of v6 back to the way it was in v5?

Andreas Roehler (a-roehler) wrote :

will introduce an option setting an one-for-all output buffer

Changed in python-mode:
importance: Undecided → Medium
assignee: nobody → Andreas Roehler (a-roehler)
milestone: none → 6.1.1
status: New → Confirmed
Andreas Roehler (a-roehler) wrote :

`python-mode-v5-behavior' now customizable

  when `python-mode-v5-behavior' set to `t',
  py-execute-... commands will pipe code through
  `shell-command-to-string', which clears the
  output-buffer before.

  This is not the default because of some Unicode related
  error lp:550661, but might be convenient in most cases

  Does not work with IPython for the moment

HTH, cheers,

Andreas

Changed in python-mode:
status: Confirmed → Fix Committed

Thanks very much, I'll check it out.

On Tue, May 1, 2012 at 2:10 AM, Andreas Roehler
<email address hidden>wrote:

> `python-mode-v5-behavior' now customizable
>
> when `python-mode-v5-behavior' set to `t',
> py-execute-... commands will pipe code through
> `shell-command-to-string', which clears the
> output-buffer before.
>
> This is not the default because of some Unicode related
> error lp:550661, but might be convenient in most cases
>
> Does not work with IPython for the moment
>
> HTH, cheers,
>
> Andreas
>
> ** Changed in: python-mode
> Status: Confirmed => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/990079
>
> Title:
> Output from v6 of python-mode different from v5
>
> Status in An Emacs mode for editing Python code:
> Fix Committed
>
> Bug description:
> In python-mode v5, when I executed py-execute-buffer on a python
> script I would get a split window, viewing a buffer called *Python
> Output*, that had only the output from executing the script, hello
> world, or whatever.
>
> In python-mode v6, when I execute the same script, I get split window
> with a buffer that has a running python shell, with the output
>
>
> Python 2.7.3 (default, Apr 19 2012, 00:55:09)
> [GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)] on
> darwin
> Type "help", "copyright", "credits" or "license" for more information.
> ## executing temporary file
> /var/folders/71/3g808qx93s5_lv0kgpkzy5z80000gp/T/Python25335pPA.py...
> >>> Hello, world
>
> The problem is that the v5 behavior is much more convenient, and I've
> gotten used to running scripts this way. Is there any way to set the
> behavior of v6 back to the way it was in v5?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/python-mode/+bug/990079/+subscriptions
>

--
Rick Muller
<email address hidden>
505-750-7557

Changed in python-mode:
status: Fix Committed → Fix Released
Rick Muller (rpmuller) wrote :

That's great. Thanks!

On Tue, May 8, 2012 at 2:28 AM, Andreas Roehler
<email address hidden>wrote:

> ** Changed in: python-mode
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/990079
>
> Title:
> Output from v6 of python-mode different from v5
>
> Status in An Emacs mode for editing Python code:
> Fix Released
>
> Bug description:
> In python-mode v5, when I executed py-execute-buffer on a python
> script I would get a split window, viewing a buffer called *Python
> Output*, that had only the output from executing the script, hello
> world, or whatever.
>
> In python-mode v6, when I execute the same script, I get split window
> with a buffer that has a running python shell, with the output
>
>
> Python 2.7.3 (default, Apr 19 2012, 00:55:09)
> [GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)] on
> darwin
> Type "help", "copyright", "credits" or "license" for more information.
> ## executing temporary file
> /var/folders/71/3g808qx93s5_lv0kgpkzy5z80000gp/T/Python25335pPA.py...
> >>> Hello, world
>
> The problem is that the v5 behavior is much more convenient, and I've
> gotten used to running scripts this way. Is there any way to set the
> behavior of v6 back to the way it was in v5?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/python-mode/+bug/990079/+subscriptions
>

--
Rick Muller
<email address hidden>
505-750-7557

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers