An Emacs mode for editing Python code

pymacs gives false message if not properly installed

Reported by tlroche on 2011-09-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
python-mode.el
Medium
Andreas Roehler

Bug Description

summary: if misinstalled, invocation of pymacs (e.g., `M-x pymacs-eval`) gives the immediate error

> Pymacs helper did not start within 30 seconds

This is unhelpful, even mystifying, given that the message is issued less than 1 s after the command. I assert that pymacs should give the user an error that assists the user in correcting the problem.

details:

I recently installed the current-latest-available pymacs as described in more detail @

https://bugs.launchpad.net/python-mode/+bug/852287

I attempted to verify my install as instructed by

http://pymacs.progiciels-bpi.ca/pymacs.html#installation

by

0 `M-x load-library pymacs`, which was successful

1 editing python-related elisp called from my init.el

me@it:~$ fgrep -ie 'pymacs' ~/.emacs.d/tlrPython.el
> (concat LOCAL-PYTHON-LISP-DIR "/pymacs")
> ;; pymacs
> (autoload 'pymacs-apply "pymacs")
> (autoload 'pymacs-call "pymacs")
> (autoload 'pymacs-eval "pymacs" nil t)
> (autoload 'pymacs-exec "pymacs" nil t)
> (autoload 'pymacs-load "pymacs" nil t)

2 restarting emacs

3 `M-x pymacs-eval repr(2L**111)`, per

http://pymacs.progiciels-bpi.ca/pymacs.html#installation
> To check this, start a fresh Emacs session, and type M-x pymacs-eval
> Emacs should prompt you for a Python expression. Try repr(2L**111) RET [...]
> The mini buffer should display "2596148429267413814265248164610048L"

While I got the prompt

> Python expression?

when I entered

> repr(2L**111)

at the prompt, and hit Enter, I got immediately (i.e., after less than 1 sec) the error message

> Pymacs helper did not start within 30 seconds

in the minibuffer. I found this mystifying until, while corresponding with François Pinard, I realized that pymacs had not installed itself to my python (as detailed in bug=852287).

HTH, Tom Roche <email address hidden>

Changed in python-mode:
assignee: nobody → Andreas Roehler (a-roehler)
importance: Undecided → Medium
Andreas Roehler (a-roehler) wrote :

Hi Tom,

beside related remarks done at bug 852287

could you communicate the hints, how to make it work. Last time I tried, got the same error.

Thanks,

Andreas

Changed in python-mode:
milestone: none → 6.0.4
Changed in python-mode:
status: New → Fix Committed
Changed in python-mode:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints