An Emacs mode for editing Python code

Add custom switch for ffap hooks

Reported by Georg Brandl on 2013-02-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-mode.el
Medium
Andreas Roehler

Bug Description

See https://answers.launchpad.net/python-mode/+question/221144

The ffap-alist entries should not be done unconditionally.

Changed in python-mode:
assignee: nobody → Andreas Roehler (a-roehler)
importance: Undecided → High
milestone: none → 6.1.1
Andreas Roehler (a-roehler) wrote :

Importance lowered to "medium", as it seems related, but not the cause of wrong keys reported.

Changed in python-mode:
importance: High → Medium
Georg Brandl (gbrandl) wrote :

Why do you say that?

Andreas Roehler (a-roehler) wrote :

Don't see where the keys mentioned should be set by python-mode. Maybe wrong?

Andreas Roehler (a-roehler) wrote :

As for the disturbance from completing code in python-shell, these processes probably should get it's own shell.

Georg Brandl (gbrandl) wrote :

There are no keys bound. The questionable code is these two forms:

(eval-after-load "ffap"
  '(progn
     (push '(python-mode . py-ffap-module-path) ffap-alist)
     (push '(inferior-python-mode . py-ffap-module-path) ffap-alist)))

(eval-after-load "ffap"
  '(push '(python-mode . py-module-path) ffap-alist))

There should be a switch to disable these.

Changed in python-mode:
status: New → In Progress
Changed in python-mode:
status: In Progress → Fix Committed
Changed in python-mode:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions