An Emacs mode for editing Python code

interaction between python-mode.el and org-mode.el causes traceback.

Reported by Greg Novak on 2013-01-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-mode.el
High
Andreas Roehler

Bug Description

If I load a python source file using python-mode.el, and then subsequently look at a .org file using org-mode.el, I get an error:

Lisp error: (wrong-type-argument stringp nil)

and then I cannot see my .org file (nothing is displayed in the buffer).

Specifically the steps to reproduce are:

1) run 'emacs --no-site-file --no-init-file'
2) eval "(require 'python-mode)" to load python-mode.el
3) find-file "some/python/file.py"
4) find-file "some/org/file.org"

and I get the above error. If any of the above steps are omitted (ie, if I load python-mode.el, but don't actually look at a python file), I don't get the error. I've included a traceback below. I'm also submitting this to as a bug to org-mode.

I'm running:
OS X 10.7.5
Emacs 24.2.1
org-mode 7.8.11
python-mode 6.1.0

Backtrace follows:

Debugger entered--Lisp error: (wrong-type-argument stringp nil)
  re-search-forward(nil nil move)
  outline-end-of-heading()
  outline-show-heading()
  #[nil " X\205 \302 \207" [outline-level levels outline-show-heading] 2]()
  outline-map-region(#[nil " X\205 \302 \207" [outline-level levels outline-show-heading] 2] 1 289092)
  hide-sublevels(1)
  org-overview()
  org-cycle-internal-global()
  org-cycle((4))
  org-set-startup-visibility()
  org-mode()
  set-auto-mode-0(org-mode nil)
  set-auto-mode()
  normal-mode(t)
  after-find-file(nil t)
  find-file-noselect-1(#<buffer work.org> "~/Dropbox/Brain/work.org" nil nil "~/Dropbox/Brain/work.org" (41138354 234881026))
  find-file-noselect("~/Dropbox/Brain/work.org" nil nil t)
  find-file("~/Dropbox/Brain/work.org" t)
  call-interactively(find-file nil nil)

Changed in python-mode:
milestone: none → 6.1.1
assignee: nobody → Andreas Roehler (a-roehler)
importance: Undecided → High
Andreas Roehler (a-roehler) wrote :

Can't reproduce. Might be fixed already.
Please check out current trunk from bazaar

bzr branch lp:python-mode

Greg Novak (greg-novak) wrote :

Indeed, seems to work now. Apologies for the spurious report.

Changed in python-mode:
status: New → Fix Committed
Changed in python-mode:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers