An Emacs mode for editing Python code

split-switch-side-effects

Reported by Andreas Roehler on 2012-11-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-mode.el
High
Andreas Roehler

Bug Description

Am 09.11.2012 18:02, schrieb Yaroslav Halchenko:> During my fasco with shebang line (that bug report I just opened, please
> close):
>
> but now interesting side-effect regarding splitting/focusing:
> While working with *ubp Python" I first enabled splitting and switch, made only code buffer and *ubp Python* visible, disabled splitting AND then it started doing what I wanted -- no additional splitting upon C-c C-c -- just switching focus to the interpreter
>
> Then I "Enforce py-shell-name", started my *Ipython" with C-c! (since it
> was in shebang) but now shit got loose -- whenever I do C-c C-c, even
> though *Ipython* is visible, current buffer switches from code to yet
> another view of *IPython* heh heh
>
> ok -- remembered about your hint on
>
> py-max-split-windows is a variable defined in `python-mode.el'.
> Its value is 2
>
> enabled splitting and switch -- C-c C-c resulted in 3 buffers (from 2):
> code, *Python*, "*IPython*". you can see coursor jumpbing from code, to
> Python and then to IPython upon C-c C-c -- happens all the time and if
> *Python* is not visible -- would split/bring it up, jump through it.
> reproducible:
>
> opened again
>
> #emacs: -*- mode: python; py-indent-offset: 4; tab-width: 4; indent-tabs-mode: nil -*-
> #ex: set sts=4 ts=4 sw=4 noet:
>
>
> class X:
> XX = [
> "asdfasdF",
> "asdfasdf",
> # lakjsdflkjasdf
> "lkajsdlkfj"
> ]
>
> print X
>
> set splitting and switch on, C-c C-c results in 4 buffers (ufff, with 2
> of code), and C-c C-c jumps though *Python*....
>
> ufffff
>

Changed in python-mode:
milestone: none → 6.1.0
assignee: nobody → Andreas Roehler (a-roehler)
importance: Undecided → High
status: New → In Progress
Andreas Roehler (a-roehler) wrote :

Could not reproduce, however made some change which should improve it.

Do you get still it? If yes, some different example might help.

Changed in python-mode:
status: In Progress → Fix Committed
Changed in python-mode:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers