pymacs.el in python-mode clobbers Pymacs's version

Bug #1071451 reported by Vinod on 2012-10-25
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Andreas Roehler

Bug Description

Based on this comment (, it seems that Pymacs is not meant to function properly in the current version of python-mode. Yet, pymacs.el remains in the main directory of python-mode. This can cause problems if you've installed Pymacs from the original source because the python-mode version of pymacs.el gets loaded and it does not work with the installed from the original source.

I'm not certain if there's a plan to re-implement Pymacs integration in python-mode, but if not, we should remove pymacs.el to avoid clashes.

Just FYI, python-mode works great with Pymacs and pycomplete.el once I got over that hurdle.

Related branches

Changed in python-mode:
milestone: none → 6.1.2
assignee: nobody → Andreas Roehler (a-roehler)
milestone: 6.1.2 → 6.1.0
importance: Undecided → Medium
status: New → In Progress
Changed in python-mode:
status: In Progress → Fix Committed
Changed in python-mode:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers