check-newsbugs.py LaunchpadLoginError; should be ported to launchpadlib

Bug #354985 reported by Bob Tanner
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Low
Vincent Ladeuil
python-launchpad-bugs
Undecided
Unassigned

Bug Description

Bug 111227 was mentioned in NEWS but is not marked as affecting bzr
  File "/usr/lib/python2.5/site-packages/launchpadbugs/text_bug.py", line 164, in parse
    text = self.__connection.get(self.__url).text
  File "/usr/lib/python2.5/site-packages/launchpadbugs/http_connection.py", line 253, in get
    return self._safe_urlopen(url, None, False)
  File "/usr/lib/python2.5/site-packages/launchpadbugs/http_connection.py", line 316, in _safe_urlopen
    raise exceptions.LaunchpadLoginError(url)
launchpadbugs.exceptions.LaunchpadLoginError:
    * message: To continue, you must log in to Launchpad.
    * url: https://bugs.launchpad.net/bzr/+bug/341517/+text

Try to access the bug url above gives me Forbidden Error:

Not allowed here

Sorry, you don't have permission to access this page.

You are logged in as Bob Tanner.

Related branches

Revision history for this message
Bob Tanner (tanner) wrote :

Related to the official releasing process of checking the NEWS file to confirm all listed bugs are closed.

Revision history for this message
Jelmer Vernooij (jelmer) wrote :

we should probably switch to launchpadlib, as that might not refuse more than X requests in a row since it uses the proper API.

Changed in python-launchpad-bugs:
status: New → Invalid
Changed in bzr:
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Martin Pool (mbp) wrote : Re: [Bug 354985] Re: check-newsbugs.py LaunchpadLoginError

I saw that too.

--
Martin <http://launchpad.net/~mbp/>

Martin Pool (mbp)
Changed in bzr:
status: Triaged → Confirmed
Revision history for this message
Martin Pool (mbp) wrote :

Changing to launchpadlib would also make it easy to fix the problem that this script gets quite confused by bugs with multiple tasks. (python-launchpad-bugs seems to just do screenscraping or something similar.)

tags: added: headache launchpad
summary: - check-newsbugs.py LaunchpadLoginError
+ check-newsbugs.py LaunchpadLoginError; should be ported to launchpadlib
Revision history for this message
Robert Collins (lifeless) wrote :

see also bug 586430 and bug 586432

Jelmer Vernooij (jelmer)
Changed in bzr:
status: Confirmed → Fix Committed
Revision history for this message
Vincent Ladeuil (vila) wrote :

The script is now using hydrazine and display private bugs as such.

Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
milestone: none → 2.3b4
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers