Implement mechanism to reduce number of one-shot sessions

Bug #245552 reported by Markus Korn on 2008-07-04
6
Affects Status Importance Assigned to Milestone
python-launchpad-bugs
Undecided
Markus Korn

Bug Description

Authentication via
   bug.authentication = {"password": "mypassword", "email": "<email address hidden>"}
causes problems (one-shot sessions) in the production db of launchpad.

We could solve this issue on the py-lp-bugs side by dumping the resulting cookie object automatically to a file and try to use the resulting cookie file as often as possible.

Markus

Daniel Holbach (dholbach) wrote :

Is bug.authentication = {"password": "mypassword", "email": "<email address hidden>"} actually the problem?

As I understood it the problem is that lots of scripts don't use any form of authentication at all.

Markus Korn (thekorn) wrote :

Ok, after some playing around with login+cookies in launchpad I think I finally understand how this all works.
Fixing this by having a 'default' cookie, actually one for each server (|edge|staging), looks easy but requires some fundamental changes to the code and to the way authentication works with python-launchpad-bugs.

So my question is: must we fix this bug before releasing py-lp-bugs 0.3?

Markus

Daniel Holbach (dholbach) wrote :

Kiko: what's your take on it?

Brian Murray (brian-murray) wrote :

This was merged into main revno 139 or so.

Changed in python-launchpad-bugs:
assignee: nobody → thekorn
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers