Kingbird commands not working with openstack cli.

Bug #1723041 reported by Mounika Sreeram on 2017-10-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-kingbirdclient
Status tracked in Queens
Queens
High
Mounika Sreeram

Bug Description

Currently, as per this commit https://review.openstack.org/#/c/500506/ plugin for openstack cli should be avaialble but it is not

$ openstack sync list
Error(app).

Please check

thanks in advance .

Revision history for this message
Goutham Pratapa (pratapagoutham) wrote :

This issue is because there are no entry point in setup.cfg without which the binding between openstack client and openstack plugin written in kingbirdclient wont work.

The issue will be fixed soon.

Thanks in advance.
Goutham

Changed in python-kingbirdclient:
status: New → Confirmed
Changed in python-kingbirdclient:
importance: Undecided → High
assignee: nobody → Goutham Pratapa (pratapagoutham)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to python-kingbirdclient (master)

Reviewed: https://review.openstack.org/511469
Committed: https://git.openstack.org/cgit/openstack/python-kingbirdclient/commit/?id=78c3169c4a6b395ef6b08127459691c382c700ab
Submitter: Jenkins
Branch: master

commit 78c3169c4a6b395ef6b08127459691c382c700ab
Author: Goutham Pratapa <email address hidden>
Date: Thu Oct 12 17:47:35 2017 +0530

    Fix Openstack Plugin issues for KB-commands.

    Currently, as per this commit https://review.openstack.org/#/c/500506/ plugin for
    openstack cli should be available but it is not because there are
    no entry points in setup.cfg in kb-client without
    which binding between openstack client and openstack plugin
    written in kb-client wont work.

    Change-Id: I400ce4765e949536819796dad0cdbc85d3a440a5
    Closes-Bug:#1723041

Changed in python-kingbirdclient:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers