GnomeKeyring was imported without specifying a version first.

Bug #1517907 reported by Attila Fazekas on 2015-11-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-keystoneclient
Low
Attila Fazekas

Bug Description

All client using python-keystoneclient throws the following error on my notebook:

$nova list
$openstack server list
$ keystone token-get
/usr/lib/python2.7/site-packages/keyring/backends/Gnome.py:6: PyGIWarning: GnomeKeyring was imported without specifying a version first. Use gi.require_version('GnomeKeyring', '1.0') before import to ensure that the right version gets loaded.

or

/usr/lib/python2.7/site-packages/keyring/backends/Gnome.py:6: PyGIWarning: GnomeKeyring was imported without specifying a version first. Use gi.require_version('GnomeKeyring', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import GnomeKeyring

$pip list |grep keyring
keyring (5.0)

Please try to avoid this warning.

description: updated
description: updated
Attila Fazekas (afazekas) wrote :

Looks like the issue is actually in the old keyring package.

Steve Martinelli (stevemar) wrote :

this is definitely coming from keyring, i'll mark this as low importance and in-progress, but there isn't much we can do about this in KSC

Changed in python-keystoneclient:
importance: Undecided → Low
status: New → In Progress
assignee: nobody → Attila Fazekas (afazekas)
Steve Martinelli (stevemar) wrote :

this was fixed here: https://github.com/openstack/python-keystoneclient/commit/7c1a67aa608d4ae36cc0e8db8ad29fbdf499b382 and will be released in the next keystoneclient release (soon)

Changed in python-keystoneclient:
status: In Progress → Fix Released
status: Fix Released → Fix Committed
Steve Martinelli (stevemar) wrote :

This issue was fixed in openstack/python-keystoneclient 2.1.0 release.

Changed in python-keystoneclient:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers