[RFE] openstackclient cmd for 'ironic driver-properties'

Bug #1619053 reported by Ruby Loo on 2016-08-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-ironicclient
Fix Released
Wishlist
Ruby Loo

Bug Description

We do not yet have an openstackclient command that provide the same functionality as 'ironic driver-properties'.

recap: 'ironic driver-properties' returns a table with two columns, the names of properties and their descriptions. These properties are what needs to be populated in a node's driver_info.

Some possibilities:

openstack baremetal driver show --properties
   pro. properties are part of a driver, so it fits here
   con. the information returned is different that the info returned w/o --properties
   Trying to return the driver info AND the properties is ugly because the table would need to
   include both 'types' of information

openstack baremetal driver properties show
   pro. it is clear what it is?
   con. Not sure this conforms to openstackclient 'philosophy'. Is a 'driver properties'
        an object? All we do is display this information; it cannot be manipulated.

Dmitry Tantsur (divius) on 2016-09-05
Changed in python-ironicclient:
status: New → Confirmed
importance: Undecided → Wishlist
no longer affects: ironic

Fix proposed to branch: master
Review: https://review.openstack.org/381153

Changed in python-ironicclient:
assignee: nobody → Galyna Zholtkevych (gzholtkevych)
status: Confirmed → In Progress

Actually, there are several solutions (see screenshots)

1. openstack baremetal driver show <driver> --properties
Show driver info with properties in a user-friendly table
But driver info is actually redundant information,
because name of the driver and its hosts you can see in

openstack baremetal driver list .

And typing show command you already know the name of the driver
Actually, I think that the show command without properties or other
additional properties does not show the useful info about driver that we don't know.
Thus, the command can be implemented just as

openstack baremetal driver show <driver>
and show driver properties by default

3. openstack baremetal driver show <driver> --properties
and show only the properties without driver info.
If driver info itself is extended I am not sure that
this solution will satisfy openstack conventions

IMHO, the best is the second one

The next screenshot for solutions 1 and 2

Ruby Loo (rloo) wrote :

There is a spec patch to address this: https://review.openstack.org/#/c/439907/

Changed in python-ironicclient:
assignee: Galyna Zholtkevych (gzholtkevych) → Ruby Loo (rloo)
Ruby Loo (rloo) wrote :

The command we decided upon is 'openstack baremetal driver property list <driver>'.

Reviewed: https://review.openstack.org/381153
Committed: https://git.openstack.org/cgit/openstack/python-ironicclient/commit/?id=58fe82082bbd72d66c52e8683efe7e9a75a238fd
Submitter: Jenkins
Branch: master

commit 58fe82082bbd72d66c52e8683efe7e9a75a238fd
Author: Galyna Zholtkevych <email address hidden>
Date: Mon Oct 3 17:08:52 2016 +0300

    Add OSC 'baremetal driver property list' command

    Extends OSC plugin with the new command:
        openstack baremetal driver property list <driver>
    This returns a list of the names of a driver's properties
    along with their descriptions.

    Change-Id: I4419daa68928a479971dab80806f0dfac37224a4
    Closes-Bug: 1619053
    Co-Authored-By: Ruby Loo <email address hidden>

Changed in python-ironicclient:
status: In Progress → Fix Released

This issue was fixed in the openstack/python-ironicclient 1.14.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers