Functional test job is broken

Bug #1491778 reported by Anton Arefiev on 2015-09-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-ironicclient
Fix Released
Medium
Jim Rollenhagen

Bug Description

Functional tests fail with following traceback:

2015-09-02 09:01:20.402 | 2015-09-02 09:01:20.338 | FAIL: ironicclient.tests.functional.test_ironicclient.TestIronicClient.test_node_create_get_delete
2015-09-02 09:01:20.436 | 2015-09-02 09:01:20.339 | tags: worker-0
2015-09-02 09:01:20.436 | 2015-09-02 09:01:20.340 | ----------------------------------------------------------------------
2015-09-02 09:01:20.436 | 2015-09-02 09:01:20.342 | Traceback (most recent call last):
2015-09-02 09:01:20.437 | 2015-09-02 09:01:20.343 | File "ironicclient/tests/functional/test_ironicclient.py", line 30, in setUp
2015-09-02 09:01:20.437 | 2015-09-02 09:01:20.344 | self.client = ironicclient.client.get_client(**self._get_config())
2015-09-02 09:01:20.437 | 2015-09-02 09:01:20.345 | File "ironicclient/tests/functional/test_ironicclient.py", line 64, in _get_config
2015-09-02 09:01:20.438 | 2015-09-02 09:01:20.346 | (config_file, auth_strategy, ','.join(missing)))
2015-09-02 09:01:20.438 | 2015-09-02 09:01:20.347 | File "/opt/stack/new/python-ironicclient/.tox/functional/local/lib/python2.7/site-packages/unittest2/case.py", line 690, in fail
2015-09-02 09:01:20.438 | 2015-09-02 09:01:20.348 | raise self.failureException(msg)
2015-09-02 09:01:20.438 | 2015-09-02 09:01:20.349 | AssertionError: Missing required setting in test.conf (ironicclient/tests/functional/test.conf) for auth_strategy=keystone: os_tenant_name,os_auth_url,os_username,os_password

The problem is test env can't get os credentials, user stack doesn't preserve existing environment variables.

Anton Arefiev (aarefiev) on 2015-09-03
Changed in python-ironicclient:
assignee: nobody → Anton Arefiev (aarefiev)
importance: Undecided → Medium
Changed in python-ironicclient:
status: New → In Progress
Changed in python-ironicclient:
assignee: Anton Arefiev (aarefiev) → Jim Rollenhagen (jim-rollenhagen)

Reviewed: https://review.openstack.org/217135
Committed: https://git.openstack.org/cgit/openstack/python-ironicclient/commit/?id=156ca47f92aba711c4c6a34d53003d2192886b86
Submitter: Jenkins
Branch: master

commit 156ca47f92aba711c4c6a34d53003d2192886b86
Author: Anton Arefiev <email address hidden>
Date: Wed Aug 26 14:35:09 2015 +0300

    Fix functional tests job

    Functional tests job are broken. This change proposes add post
    test hook in ironicclient, which will be executed inside
    post_test_hook function in devstack gate.

    The benefit from this approach is it will immediately pick up
    proposed fixes on ironicclient side and runs job. It allows us
    to see the change breaks tests or not w/o merging related
    changes.

    post_test_hook runs functional tests and generate testr results
    (original implementation was stolen from novaclient).

    Closes-Bug: #1491778
    Change-Id: Id476430d01a57a83bd4ee42b2d03e681835dfec3

Changed in python-ironicclient:
status: In Progress → Fix Committed
Changed in python-ironicclient:
milestone: none → 0.8.1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers