documentation doesn't build using python3

Bug #1843407 reported by Ralf Haferkamp on 2019-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-glareclient
Undecided
Unassigned

Bug Description

Trying to build the documentation currently fails with:

> python3 setup.py build_sphinx
running build_sphinx
[pbr] Writing ChangeLog
[pbr] Generating ChangeLog
[pbr] ChangeLog complete (0.0s)
[pbr] Generating AUTHORS
[pbr] AUTHORS complete (0.0s)
Running Sphinx v2.2.0
loading pickled environment... failed
failed: build environment version not current

Exception occurred:
  File "/home/rhafer/local/suse-cloud/openstack/python-glareclient/venv37/lib/python3.7/site-packages/oslosphinx/__init__.py", line 76, in builder_inited
    app.info('Using openstack theme from %s' % theme_dir)
AttributeError: 'Sphinx' object has no attribute 'info

This is due to python-glareclient still depending on oslosphinx for the documentation which does not work with Sphinx v2. The fix would be to move to openstackdocstheme (https://docs.openstack.org/openstackdocstheme/latest/)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers