Marker option for glareclient is not available in list API

Bug #1755995 reported by Kushal Agrawal on 2018-03-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-glareclient
Medium
Kushal Agrawal

Bug Description

Currently, there is no option in glare-cli to get the next set of records in list API as it does not have the option for providing marker value in the request.

Changed in python-glareclient:
assignee: nobody → Kushal Agrawal (kushal2605)
importance: Undecided → Medium
status: New → Confirmed
Changed in python-glareclient:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/559984
Committed: https://git.openstack.org/cgit/openstack/python-glareclient/commit/?id=98d2a4deb7ccd8635ab2d4f21a5601922990a44d
Submitter: Zuul
Branch: master

commit 98d2a4deb7ccd8635ab2d4f21a5601922990a44d
Author: Kushal Agrawal <email address hidden>
Date: Tue Apr 10 16:11:26 2018 +0530

    Marker support for next page in list command

    Marker is required to get the next page in list api
    in case there are more records available either because of
    custom limit provided in request or because of default limit
    configured in system (client and server).

    ex: glare list all --limit=5 --marker=<artifact_id>

    Change-Id: I9f5c890c46b7f1f1e6fefdb7320c4fe00a2b0972
    Closes-bug: #1755995

Changed in python-glareclient:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers