Python templates should use dh_python2

Bug #894582 reported by Allison Randal
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-distutils-extra
Fix Released
Undecided
Unassigned

Bug Description

The Quickly templates for Python should use dh_python2. python-support has been deprecated:

http://lists.debian.org/debian-python/2011/06/msg00136.html

I'm reviewing the a Quickly-based submission through the ARB, which is nice and clean. But, it has a build dependency on python-support, which is a red flag. Usually I'd ask the packager to update to dh_python2, but since this is a Quickly app, manually altering the generated package files probably isn't the best approach.

Revision history for this message
Didier Roche-Tolomelli (didrocks) wrote :

the modification needs to be made in python-distutils-extra I guess.

affects: quickly → python-distutils-extra
Revision history for this message
Andrew Mitchell (ajmitch) wrote :

python-distutils-extra (2.31-3) unstable; urgency=low

  [ Michael Vogt ]
  * python-mkdebian: Update to use dh_python2, dh7 and a more current DEP-5
    format.

  [ Martin Pitt ]
  * python-mkdebian: In above dh7 conversion, use the "translations" module if
    available (for Ubuntu's dh-translations).

 -- Martin Pitt <email address hidden> Tue, 03 Jan 2012 17:09:28 +0100

Changed in python-distutils-extra:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers