Add a --build-dependency flag to python-mkdebian

Bug #1032010 reported by Michael Terry on 2012-08-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-distutils-extra
Undecided
Unassigned

Bug Description

python-mkdebian has support for adding a new runtime dependency via --dependency. But sometimes a package will do something funky in setup.py and it knows it will need a special build-dependency. There should be a corresponding --build-dependency flag.

My immediate example is quickly, which knows it will need libglib2.0-bin for glib-compile-schemas if it is creating a package for ARB. But really, it could be any weird requirement from setup.py.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers