Invocation error: tempest verify-config: error: unrecognized arguments: -uro ../../../../tmp/tmp.FR5OHabb3Y

Bug #1543841 reported by Madhusudhan Kandadai
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
cliff
In Progress
Undecided
Dean Troyer
devstack
Fix Released
Undecided
Matthew Treinish
oslo.config
Invalid
Undecided
Unassigned
tempest
Invalid
Undecided
Unassigned

Bug Description

While setting up devstack master branch with tempest, it fails as below:

2016-02-09 22:58:50.906 | ++ /home/devstack/devstack/lib/tempest:configure_tempest:L324: tox -revenv -- tempest verify-config -uro /tmp/tmp.BSySCymzO9
2016-02-09 22:58:51.572 | venv create: /opt/stack/tempest/.tox/venv
2016-02-09 22:58:57.282 | venv installdeps: -r/opt/stack/tempest/requirements.txt, -r/opt/stack/tempest/test-requirements.txt
2016-02-09 22:59:22.642 | venv develop-inst: /opt/stack/tempest
2016-02-09 22:59:32.954 | venv installed: anyjson==0.3.3,appdirs==1.4.0,Babel==2.2.0,cffi==1.5.0,cliff==1.16.0,cmd2==0.6.8,coverage==4.0.3,cryptography==1.2.2,debtcollector==1.2.0,docutils==0.12,ecdsa==0.13,enum34==1.1.2,extras==0.0.3,fasteners==0.14.1,fixtures==1.4.0,flake8==2.2.4,funcsigs==0.4,functools32==3.2.3.post2,hacking==0.10.2,httplib2==0.9.2,idna==2.0,ipaddress==1.0.16,iso8601==0.1.11,Jinja2==2.8,jsonschema==2.5.1,keystoneauth1==2.2.0,linecache2==1.0.0,MarkupSafe==0.23,mccabe==0.2.1,mock==1.3.0,monotonic==0.6,mox==0.5.3,mox3==0.13.0,msgpack-python==0.4.7,netaddr==0.7.18,netifaces==0.10.4,os-client-config==1.14.0,os-testr==0.6.0,oslo.concurrency==3.4.0,oslo.config==3.6.0,oslo.context==2.0.0,oslo.i18n==3.2.0,oslo.log==2.3.0,oslo.serialization==2.2.0,oslo.utils==3.4.0,oslosphinx==4.2.0,oslotest==2.0.0,paramiko==1.16.0,pbr==1.8.1,pep8==1.5.7,prettytable==0.7.2,pyasn1==0.1.9,pycparser==2.14,pycrypto==2.6.1,pyflakes==0.8.1,Pygments==2.1,pyinotify==0.9.6,pyOpenSSL==0.15.1,pyparsing==2.1.0,pyrsistent==0.11.12,python-dateutil==2.4.2,python-mimeparse==1.5.1,python-subunit==1.2.0,pytz==2015.7,PyYAML==3.11,requests==2.9.1,requestsexceptions==1.1.3,retrying==1.3.3,six==1.10.0,Sphinx==1.2.3,stevedore==1.10.0,-e git://git.openstack.org/openstack/tempest.git@993a6f58f158f343f0d4168866c16e0ad9793f32#egg=tempest,tempest-lib==0.14.0,testrepository==0.0.20,testscenarios==0.5.0,testtools==2.0.0,traceback2==1.4.0,unicodecsv==0.14.1,unittest2==1.1.0,wheel==0.29.0,wrapt==1.10.6
2016-02-09 22:59:32.954 | venv runtests: PYTHONHASHSEED='3688519842'
2016-02-09 22:59:32.954 | venv runtests: commands[0] | tempest verify-config -uro ../../../tmp/tmp.BSySCymzO9
2016-02-09 22:59:33.685 | usage: tempest verify-config [-h] [-u] [-o OUTPUT] [-r]
2016-02-09 22:59:33.685 | tempest verify-config: error: unrecognized arguments: -uro ../../../tmp/tmp.BSySCymzO9
2016-02-09 22:59:33.720 | ERROR: InvocationError: '/opt/stack/tempest/.tox/venv/bin/tempest verify-config -uro ../../../tmp/tmp.BSySCymzO9'
2016-02-09 22:59:33.720 | ___________________________________ summary ____________________________________
2016-02-09 22:59:33.720 | ERROR: venv: commands failed
2016-02-09 22:59:33.734 | + /home/devstack/devstack/lib/tempest:configure_tempest:L1: exit_trap

tags: removed: oslo
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to devstack (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/278151

Revision history for this message
Matthew Treinish (treinish) wrote :

Doesn't look like oslo.config is coming into play here. It's not even being used by the options which changed. Cliff is the only thing being used by the cli command which is failing and it also just released.

Changed in oslo.config:
status: New → Invalid
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to devstack (stable/liberty)

Related fix proposed to branch: stable/liberty
Review: https://review.openstack.org/278160

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to devstack (stable/liberty)

Reviewed: https://review.openstack.org/278160
Committed: https://git.openstack.org/cgit/openstack-dev/devstack/commit/?id=380c6a4573232a6388357ad2b9a048940eeecf47
Submitter: Jenkins
Branch: stable/liberty

commit 380c6a4573232a6388357ad2b9a048940eeecf47
Author: Matthew Treinish <email address hidden>
Date: Tue Feb 9 19:19:48 2016 -0500

    Switch tempest verify-config usage to avoid bug

    This commit will unblock the world breakage caused by the recent
    cliff release. This exposes a hole in our constraints usage in
    devstack. We need to fix this bug for real in devstack and cliff,
    but that will take a few minutes to an hour or so. So let's just
    change the usage in the meantime, we can revert this when things
    are fixed for real.

    Change-Id: Ic63612dc50e064a3a69b88618e394ba17e083c22
    Related-Bug: #1543841

tags: added: in-stable-liberty
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to devstack (master)

Reviewed: https://review.openstack.org/278151
Committed: https://git.openstack.org/cgit/openstack-dev/devstack/commit/?id=1a9e294ff398e5f3c3a0a62621b8872273aeb0f9
Submitter: Jenkins
Branch: master

commit 1a9e294ff398e5f3c3a0a62621b8872273aeb0f9
Author: Matthew Treinish <email address hidden>
Date: Tue Feb 9 18:51:02 2016 -0500

    Switch tempest verify-config usage to avoid bug

    This commit will unblock the world breakage caused by the recent
    cliff release. This exposes a hole in our constraints usage in
    devstack. We need to fix this bug for real in devstack and cliff,
    but that will take a few minutes to an hour or so. So let's just
    change the usage in the meantime, we can revert this when things
    are fixed for real.

    Related-Bug: #1543841

    Depends-On: Ic63612dc50e064a3a69b88618e394ba17e083c22
    Change-Id: I19e477fa5068474bc3471307732f89adaafb2952

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to devstack (master)

Fix proposed to branch: master
Review: https://review.openstack.org/278206

Changed in devstack:
assignee: nobody → Matthew Treinish (treinish)
status: New → In Progress
Revision history for this message
Davanum Srinivas (DIMS) (dims-v) wrote :

Looks like this problem was caused by:
https://review.openstack.org/#/c/262752/

So the following change in Tempest works:

diff --git a/tempest/cmd/verify_tempest_config.py b/tempest/cmd/verify_tempest_config.py
index 92aa19e..6de8b08 100644
--- a/tempest/cmd/verify_tempest_config.py
+++ b/tempest/cmd/verify_tempest_config.py
@@ -390,6 +390,7 @@ class TempestVerifyConfig(command.Command):

     def get_parser(self, prog_name):
         parser = super(TempestVerifyConfig, self).get_parser(prog_name)
+ parser.allow_abbrev = True
         _parser_add_args(parser)
         return parser

Revision history for this message
Davanum Srinivas (DIMS) (dims-v) wrote :

Looks like Dean put up a revert:
https://review.openstack.org/#/c/278781/

Revision history for this message
Steve Martinelli (stevemar) wrote :

tried this locally and yeah thats the commit

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to cliff (master)

Reviewed: https://review.openstack.org/278781
Committed: https://git.openstack.org/cgit/openstack/cliff/commit/?id=3ff91a95d702331f77885ef59ee53f572aae2928
Submitter: Jenkins
Branch: master

commit 3ff91a95d702331f77885ef59ee53f572aae2928
Author: Dean Troyer <email address hidden>
Date: Wed Feb 10 22:38:15 2016 +0000

    Revert "app,command: disallow abbrev by default"

    This reverts commit 1e3ef64179919f6c532c9bde15530040d5c1fbaa.

    This changed a default behaviour and broke tempest (and possibly more)
    when version 1.16.0 was released.

    A proper implementation that allows abbrev to be disabled without
    changing the default will follow.

    Related-Bug: 1543841
    Change-Id: Ib38617ad08d930df1dcf263f4812b746b858a245

Revision history for this message
Dean Troyer (dtroyer) wrote :

This was triggered by cliff review https://review.openstack.org/#/c/262753/ that changed an argparse default allow_abbrev=False. This is a breaking API change, and rather than change the default, a way to set allow_abbrev should have been provided/documented. https://review.openstack.org/#/c/278781/ reverted the breaking change in cliff, and will be followed by a proper way to change the argparse behaviour and some tests.

Changed in python-cliff:
status: New → In Progress
assignee: nobody → Dean Troyer (dtroyer)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to devstack (master)

Reviewed: https://review.openstack.org/278206
Committed: https://git.openstack.org/cgit/openstack-dev/devstack/commit/?id=1e31e68557205fa61929ff579e427b7ef86aa2ea
Submitter: Jenkins
Branch: master

commit 1e31e68557205fa61929ff579e427b7ef86aa2ea
Author: Matthew Treinish <email address hidden>
Date: Tue Feb 9 23:50:54 2016 -0500

    Respect constraints in tempest tox venvs

    This commit is a workaround for respecting upper-constraints. Since
    we're using tox to handle setting up a venv and running tempest
    commands we need to manually install the constrained packages inside
    the tox venvs. This patch does that for all the venvs being created by
    devstack via tox. However, since tempest has additional tox jobs
    defined if those are run via devstack those will default to the
    default pip install -U -r requirements.txt defined in tempest's
    tox.ini.

    Change-Id: I7f84dfb67a3c97003947aefd8a7e3c6454106db4
    Closes-Bug: #1543841

Changed in devstack:
status: In Progress → Fix Released
Matt Riedemann (mriedem)
Changed in tempest:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers