debug option broken on cinderclient

Bug #1130730 reported by Ollie Leahy on 2013-02-20
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
python-cinderclient
High
Ollie Leahy
python-cinderclient (Ubuntu)
Undecided
Unassigned

Bug Description

The --debug option to python-cinderclient is broken:

$ cinder --debug list
DEBUG (shell:492) hasattr(): attribute name must be string
Traceback (most recent call last):
  File "cinderclient/shell.py", line 489, in main
    OpenStackCinderShell().main(sys.argv[1:])
  File "cinderclient/shell.py", line 430, in main
    cacert=cacert)
  File "/mnt/stack/python-cinderclient/cinderclient/client.py", line 379, in Client
    return client_class(*args, **kwargs)
  File "/mnt/stack/python-cinderclient/cinderclient/v2/client.py", line 67, in __init__
    cacert=cacert)
  File "/mnt/stack/python-cinderclient/cinderclient/client.py", line 78, in __init__
    if hasattr(requests, logging):
TypeError: hasattr(): attribute name must be string
ERROR: hasattr(): attribute name must be string

Changed in cinder:
assignee: nobody → Ollie Leahy (oliver-leahy-l)
Chuck Short (zulcss) wrote :

I am not able to reproduce this, which version?

affects: cinder → python-cinderclient
John Griffith (john-griffith) wrote :
Changed in python-cinderclient:
status: New → Confirmed
importance: Undecided → High
Chuck Short (zulcss) wrote :

Apparently this is already fixed in trunk

Changed in python-cinderclient:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-cinderclient (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-cinderclient - 1:1.0.4-0ubuntu1

---------------
python-cinderclient (1:1.0.4-0ubuntu1) saucy; urgency=low

  [ Yolanda Robla ]
  * debian/tests: added autopkg tests

  [ James Page ]
  * New upstream release:
    - Fixes problem with --debug option (LP: #1130730).
  * d/control: Update VCS fields for new branch locations.
  * d/install: Enable bash completion for cinder command.
  * d/control: Drop pep8 from BD's.
  * d/control: Bumped Standards-Version to 3.9.4:
    - d/copyright: Switch to released version of DEP-5.
 -- James Page <email address hidden> Thu, 18 Jul 2013 14:45:01 +0100

Changed in python-cinderclient (Ubuntu):
status: Confirmed → Fix Released
Changed in python-cinderclient:
milestone: none → 1.3.1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers