The website - discussion.

Bug #248240 reported by Adam Rooke
2
Affects Status Importance Assigned to Milestone
PyRoom
Fix Released
Wishlist
Florian Heinle

Bug Description

At the moment the website isn't that good and I think that we should look at improving it. The information on there already is good - I just think we could make it a lot clearer.

My (X)HTML skills are pretty rusty but I could give it a go clobbering something together unless someone more qualified wants to give it a stab.

I'm thinking:
- Keep the dark idea but loose to dark green - its not that legible
- Crisper font
- Change the layout a bit and update.

Thoughts, comments?

Revision history for this message
Florian Heinle (tiax) wrote :

Why not just use the wiki and focus on content? The current website doesn't offer anything the wiki couldn't.

Revision history for this message
Nathan Haines (nhaines) wrote :

Because the website is what people will see and not the wiki.

I don't think we really need a wiki. But we do need a nice, organized, and most of all pleasant presence on the Web. I thought Caio Alonso was working on it but perhaps he became busy. I'm not sure dark is so good but it needs to be at least easily readable. Minimalist is still okay. We want to keep that aspect, I guess. :)

Revision history for this message
Adam Rooke (abelianr) wrote : Re: [Bug 248240] Re: The website - discussion.

Wiki's are actually pretty hard to navigate and find information on -
especially when you are only going to have a few pages. I would say the wiki
offers nothing the website doesn't. I will send Caio an email later to see
if he has started anything with it - if not I will begin work on it.

2008/7/14 Nathan Haines <email address hidden>:

> Because the website is what people will see and not the wiki.
>
> I don't think we really need a wiki. But we do need a nice, organized,
> and most of all pleasant presence on the Web. I thought Caio Alonso was
> working on it but perhaps he became busy. I'm not sure dark is so good
> but it needs to be at least easily readable. Minimalist is still okay.
> We want to keep that aspect, I guess. :)
>
> --
> The website - discussion.
> https://bugs.launchpad.net/bugs/248240
> You received this bug notification because you are a member of PyRoom
> Bug Squad, which is subscribed to PyRoom.
>
> Status in PyRoom: distraction-free writing: New
>
> Bug description:
> At the moment the website isn't that good and I think that we should look
> at improving it. The information on there already is good - I just think we
> could make it a lot clearer.
>
> My (X)HTML skills are pretty rusty but I could give it a go clobbering
> something together unless someone more qualified wants to give it a stab.
>
> I'm thinking:
> - Keep the dark idea but loose to dark green - its not that legible
> - Crisper font
> - Change the layout a bit and update.
>
> Thoughts, comments?
>

Revision history for this message
Andrew (and471) wrote :

I think you should go with a content management site like Drupal or Joomla! if that is possible, and then get a new dark theme.

I think ATM the site hasn't struck the 'dark minimalist' style nail on the head, it just looks like a very quickly done website.

Revision history for this message
Florian Heinle (tiax) wrote :

don't overdo the website. Do we really need dynamic parts? We should be okay with static content actually, maybe keep it in some bazaar repo and use a commit hook that renders html from markdown-formatted content

Revision history for this message
Bruno Bord (brunobord) wrote :

tiax's idea is quite good. Currently, the website is managed by a simple Django application that handles "flatpages" and menu items. I'd be delighted to grant somebody an access to the administration side, if anyone wants to improve content.

On the design side, rugby471 is right: it's been done quick and dirty. Anyone with design skill can help getting it better...

Revision history for this message
Adam Rooke (abelianr) wrote :

It was my intention that it could be a static page as tiax suggested - the
website just needs to have a bit of information that is clearly presented -
nothing over the top. I'm away at the moment but will start giving it a go
when I get back.

2008/7/15 Bruno Bord <email address hidden>:

> tiax's idea is quite good. Currently, the website is managed by a simple
> Django application that handles "flatpages" and menu items. I'd be
> delighted to grant somebody an access to the administration side, if
> anyone wants to improve content.
>
> On the design side, rugby471 is right: it's been done quick and dirty.
> Anyone with design skill can help getting it better...
>
> --
> The website - discussion.
> https://bugs.launchpad.net/bugs/248240
> You received this bug notification because you are a member of PyRoom
> Bug Squad, which is subscribed to PyRoom.
>
> Status in PyRoom: distraction-free writing: New
>
> Bug description:
> At the moment the website isn't that good and I think that we should look
> at improving it. The information on there already is good - I just think we
> could make it a lot clearer.
>
> My (X)HTML skills are pretty rusty but I could give it a go clobbering
> something together unless someone more qualified wants to give it a stab.
>
> I'm thinking:
> - Keep the dark idea but loose to dark green - its not that legible
> - Crisper font
> - Change the layout a bit and update.
>
> Thoughts, comments?
>

Revision history for this message
Florian Heinle (tiax) wrote :

Adam,

I think we should rather use HTML4 instead of XHTML (see http://hixie.ch/advocacy/xhtml - synopsis: xhtml isn't supported by browsers)

Revision history for this message
Adam Rooke (abelianr) wrote :

Good catch Tiax.

I have done a bit of research and basically if you serve XHTML properly,
rather than as malformed HTML as is the norm, only modern browsers can
handle it. IE has no capability at all to interpret it and treats a xhtml
page as a file download.

I did not realise that was a problem. Will redo it in HTML4 from now then.
2008/7/20 tiax <email address hidden>:

> Adam,
>
> I think we should rather use HTML4 instead of XHTML (see
> http://hixie.ch/advocacy/xhtml - synopsis: xhtml isn't supported by
> browsers)
>
> --
> The website - discussion.
> https://bugs.launchpad.net/bugs/248240
> You received this bug notification because you are a member of PyRoom
> Bug Squad, which is subscribed to PyRoom.
>
> Status in PyRoom: distraction-free writing: New
>
> Bug description:
> At the moment the website isn't that good and I think that we should look
> at improving it. The information on there already is good - I just think we
> could make it a lot clearer.
>
> My (X)HTML skills are pretty rusty but I could give it a go clobbering
> something together unless someone more qualified wants to give it a stab.
>
> I'm thinking:
> - Keep the dark idea but loose to dark green - its not that legible
> - Crisper font
> - Change the layout a bit and update.
>
> Thoughts, comments?
>

Revision history for this message
Adam Rooke (abelianr) wrote :

I'm going to have to give up on this. I have recently got a summer job (shameless plug www.demotix.com) and just don't have the time to dedicate to this. If anyone else wants to pick it up, they are welcome.

Revision history for this message
Florian Heinle (tiax) wrote :

ok..

try http://www.planet-tiax.de/pyroom/ for a first mockup

Changed in pyroom:
assignee: nobody → tiax
importance: Undecided → Wishlist
status: New → Confirmed
Florian Heinle (tiax)
Changed in pyroom:
status: Confirmed → In Progress
Revision history for this message
Adam Rooke (abelianr) wrote :

The first mock-up is looking good. Only one thought so far:
  You should change "Home/About PyRoom" and "About/Features and
  Screenshot" to something else. Maybe change it so the top bar reads
  "Home/About Features/Something Download/Get Pyroom Support/Problems
  and contribution". Its confusing having about in there twice.

Revision history for this message
Nathan Haines (nhaines) wrote :

Tiax, this site is really beauitful and I especially like the wording. We should make the site greener rather than greyer, but that's a really great layout and description. The bit about PyRoom being Free Software is a bit awkward, but that can be fixed before we go with that design.

Revision history for this message
Adam Rooke (abelianr) wrote :

I think the site should go greener, that is the "default" look atm. The screenshot should also be the "default" pyroom theme (green).

I think we could change the wording about it being free to this:
PyRoom is a editor that stays out your way - and keeps other things out of your way, too. As a fullscreen editor without buttons, widgets, formatting options, menus and with only the minimum of required dialog windows, it doesn't have any distractions and lets you focus on wirting and only writing. It is distributed under the GNU Public License v. 3.

There is no real need for the free gratis/libre buisness it just ends up being confusing.

Revision history for this message
Florian Heinle (tiax) wrote :

On Thu, Jul 31, 2008 at 07:13:58PM -0000, Adam Rooke wrote:
> I think the site should go greener, that is the "default" look atm. The
> screenshot should also be the "default" pyroom theme (green).

I agree about the screenshot, I changed it to the default theme in the
screenshot and uploaded a new version.

After recent comments, I tried to find a green version that looked good
and was easy on the eye. But, honestly, I couldn't find any. However, I
think it's not that big a deal. After all, PyRoom clones such as
Writeroom ;) also don't use their application theme on their websites
but use just whatever their webdesigners came up with. I don't think
users will care.

> I think we could change the wording about it being free to this:
> PyRoom is a editor that stays out your way - and keeps other things
> [...]
> wirting and only writing. It is distributed under the GNU Public
> License v. 3.
>
> There is no real need for the free gratis/libre buisness it just ends up
> being confusing.

You're right, I changed the wording. I kept the "free" before editor so
people know it's free of charge, which is a big difference from
writeroom.

Revision history for this message
Adam Rooke (abelianr) wrote :

Its starting to look good.

A few comments in the downloads section:

Maybe give some more detailed instructions on using the development version, something like this:
bzr branch lp:pyroom
cd pyroom
You can then either install pyroom, or run it from within that directory.
To install pyroom:
python setup.py install
To run:
./pyroom.py

Revision history for this message
Florian Heinle (tiax) wrote :

On Fri, Aug 01, 2008 at 12:10:10PM -0000, Adam Rooke wrote:
> Maybe give some more detailed instructions on using the development
> version, something like this:
> [snip]

Hm. That's basically the same for tarball and dev versions. And it's in
the README file. Users who can't read that will hardly get a lot of use
out of a program for writing. I feel adding that information might add
clutter to the download page and redundancy.

Revision history for this message
Adam Rooke (abelianr) wrote :

Ok, I see where you are coming from with that. Makes sense.

Just to be pedantic, put:
$ bzr branch lp:pyroom

Revision history for this message
Florian Heinle (tiax) wrote :

ok I did that

we should really get that new homepage thing out of the door with a 0.3 release. We then could promote pyroom.

Revision history for this message
Florian Heinle (tiax) wrote :

added to 0.3 milestone

Changed in pyroom:
milestone: none → 0.3
Florian Heinle (tiax)
Changed in pyroom:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers