Change selected text fg/bg colors in style properties

Bug #189262 reported by Marc Carson
2
Affects Status Importance Assigned to Milestone
PyRoom
Fix Released
Wishlist
Florian Heinle
0.3
Fix Released
Undecided
Unassigned

Bug Description

"Would be nice" to be able to change the colors of selected text on a per-style basis. This way I could make selected text in e.g. the Amber style match the theme.

Tags: lookandfeel
Bruno Bord (brunobord)
Changed in pyroom:
importance: Undecided → Medium
Revision history for this message
Adam Rooke (abelianr) wrote :

I think it will be possible to change this in the same way that we modify the cursor colour - by using gtk rc. Will have a look into it later to see if its possible

Changed in pyroom:
status: New → Confirmed
Revision history for this message
Peter Frost (slimeypete) wrote :

http://ometer.com/gtk-colors.html suggests that this might be accomplished by doing the same thing we currently do for other colours, but using STATE_SELECTED instead of STATE_NORMAL.

I might try this out tonight and see if I can make it work.

Revision history for this message
Adam Rooke (abelianr) wrote : Re: [Bug 189262] Re: Change selected text fg/bg colors in style properties

I looked at that a while ago and I think we would have to use the
gtk.rc_parse (I think dont have the code near me) that we use to change the
cursor colour. I just couldn't find the relevant bits to change - the joys
of trawling through references again. Let us know if you have any progress.

On 25/03/2008, Peter Frost <email address hidden> wrote:
>
> http://ometer.com/gtk-colors.html suggests that this might be
> accomplished by doing the same thing we currently do for other colours,
> but using STATE_SELECTED instead of STATE_NORMAL.
>
> I might try this out tonight and see if I can make it work.
>
>
> --
> Change selected text fg/bg colors in style properties
> https://bugs.launchpad.net/bugs/189262
> You received this bug notification because you are a member of PyRoom
> Bug Squad, which is subscribed to PyRoom.
>

Revision history for this message
Florian Heinle (tiax) wrote :

changed from "black foreground on selections" to "background color is new foreground color when selected" (as users would expect it, especially those with black foreground colors)

apart form that, works for me.

Changed in pyroom:
assignee: nobody → tiax
importance: Medium → Wishlist
status: Confirmed → Fix Committed
Revision history for this message
Florian Heinle (tiax) wrote :

added to 0.3 milestone

Changed in pyroom:
milestone: none → 0.3
Florian Heinle (tiax)
Changed in pyroom:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers