X509Extension/X509ExtensionType is anachronistic - only one is required in non-ancient versions of Python

Bug #312786 reported by Jean-Paul Calderone on 2008-12-31
2
Affects Status Importance Assigned to Milestone
pyOpenSSL
Fix Released
Medium
Jean-Paul Calderone

Bug Description

Ages ago, it was necessary to have a factory function for creating instances of C types separate from the C type object itself. This has long since changed, and having two different objects like this for each type (essentially all the types in pyOpenSSL suffer from this) is pointless and confusing.

The names in each pair should become synonyms for the same object. This should be the type object, and it should be possible to use the type object to instantiate the type.

Related branches

Changed in pyopenssl:
importance: Undecided → Medium
status: New → Confirmed
Changed in pyopenssl:
milestone: none → 0.10
Changed in pyopenssl:
assignee: nobody → Jean-Paul Calderone (exarkun)
status: Confirmed → Fix Committed
Changed in pyopenssl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers