cannot be easy_install'ed

Reported by Sridhar Ratnakumar on 2009-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pyLSM
Medium
Charles Roduit
Changed in pylsm:
assignee: nobody → Charles Roduit (charles-roduit)
importance: Undecided → Medium
status: New → Confirmed
Charles Roduit (charles-roduit) wrote :

Thank you for your bug report.

I've reproduced this bug in my machine.

The problem is in the pypi description of my project. I've update it to point to the correct file and now it passes this step.

Now I am blocked in a new error :

error: Could not find suitable distribution for Requirement.parse('pyLSM')

Which seems to be related to the packaging of pyLSM. I don't know yet how to do it, and will investigate further. If you have any information that can help me, do not hesitate !!

Keep this bug open as pyLSM can still not be easy_install'ed.

On Tue, 21 Jul 2009 07:05:37 -0700, Charles Roduit
<email address hidden> wrote:

> If you have any information
> that can help me, do not hesitate !!

Does your metadata (name, version, etc.. in setup.py to PKG-INFO) or the
tarball filename have unicode characters? Is all your files encoded in
utf-8?

-srid

Charles Roduit (charles-roduit) wrote :

It seems it cannot find the file from the pypi informations. The Unicode problem lied in a web address in pypi.

If I run easy_install from a local copy of the tgz file it installs the library.

sudo easy_install -smaxld pylsm_0.1-r26.orig.tgz

or if the library is in /usr/lib/... (like debian)

sudo easy_install -smaxld -d /usr/lib/python2.6/dist-packages/ pylsm_0.1-r26.orig.tgz

Sridhar Ratnakumar (srid) wrote :

My *guess* is that this is due to the use of underscore character in the tarball name. Try renaming the file to "pylsm-0.1r26.tgz"

**

Searching for pylsm
Reading http://pypi.python.org/simple/pylsm/
Reading http://www.freesbi.ch/pylsm
Found link: http://launchpad.net/pylsm/trunk/0.1/+download/pylsm_0.1-r26.orig.tgz
Found link: http://pypi.python.org/packages/2.6/p/pyLSM/pylsm_0.1-r26.orig.tgz#md5=f496f041b275afcd7e11c2ed5f7cf62f
No local packages or download links found for pylsm
error: Could not find suitable distribution for Requirement.parse('pylsm')

Charles Roduit (charles-roduit) wrote :

Your "guess" is right !

Thanks a lot for your help.

I will mark this bug as solved as the library installs correctly.

Nevertheless, I have to fine tune the installation, the script "guilsm" does not installs in the bin directory. (Is it possible to do it with easy_install ??)

Changed in pylsm:
status: Confirmed → Fix Released
Sridhar Ratnakumar (srid) wrote :

Yes, easy_install supports scripts in distutils. Run "easy_install platinfo" for a demo. Look at platinfo's setup.py .. and see what pyLSM's setup.py is missing.

Changed in pylsm:
status: Fix Released → In Progress
Charles Roduit (charles-roduit) wrote :

Thanks for all your advices Sridhar.

pyLSM is now completely easy_install'able. The scripts installs fine in the correct directory and the data files are found by the python scripts.

The release '0.1-r27' has all the needed corrections (0.1-r27).

Changed in pylsm:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers