upgrade-charm fails to change a symlink to a regular file

Bug #988115 reported by Clint Byrum on 2012-04-25
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
juju-core
Undecided
William Reade
pyjuju
High
Unassigned

Bug Description

Test case:

create a charm with upgrade-charm hook linked to install

so

hooks/install (regular executable file)
hooks/upgrade-charm -> install

Deploy this charm. Once it is deployed, change the local charm so that hooks/upgrade-charm is a regular executable file.

juju juju-upgrade-charm xxxx to upgrade the charm

I would expect the charm to be identical, but instead, upgrade-charm is still a symlink to install.

Haw Loeung (hloeung) on 2012-09-06
tags: added: canonical-webops-juju
Clint Byrum (clint-fewbar) wrote :

William I've assigned you this task because I'm wondering if your new merging code will address this in the Go port.

Changed in juju:
status: New → Confirmed
importance: Undecided → High
Changed in juju-core:
assignee: nobody → William Reade (fwereade)
William Reade (fwereade) wrote :

Clint, cheers, it certainly should but I'll verify it.

William Reade (fwereade) wrote :

There's now a test that verifies this specific behaviour.

Changed in juju-core:
status: New → Fix Released
tags: added: goju-resolved
Changed in juju:
milestone: none → 0.8
Curtis Hovey (sinzui) on 2013-10-12
Changed in juju:
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers