juju executing hooks with umask of 0077

Bug #953258 reported by Robert Ayres
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pyjuju
Fix Released
Undecided
Unassigned
juju (Ubuntu)
Fix Released
High
Unassigned
Precise
Fix Released
High
Unassigned

Bug Description

Whilst examining a HBase charm (https://bugs.launchpad.net/charms/+bug/800708), I noticed the configuration files were being copied with a umask of 0077. This was causing problems whereby the HBase daemon (running as 'hbase' user) was unable to read its configuration which was effectively private to root.

I altered one of the hooks to output the umask to a temporary file and after getting juju to execute the hook, this was indeed reporting 0077.

After an irc conversation, this doesn't appear to be by design and may have been fixed in juju r460+ with a '--nodaemon' flag to twisted. I have not tested this.

Version: 0.5+bzr457-0ubuntu1, Ubuntu Precise Server

Related branches

Revision history for this message
Robert Ayres (robert-ayres) wrote :

Tested with 0.5+bzr478-1juju3~precise1 and no longer a problem.
Executing hooks now have a umask of 644 (or presumably whatever the system default is).

Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Robert, thanks for testing! Will mark as affecting precise.

Changed in juju:
status: New → Fix Released
Changed in juju (Ubuntu Precise):
importance: Undecided → High
milestone: none → ubuntu-12.04-beta-2
tags: added: rls-mgr-p-tracking
Changed in juju (Ubuntu Precise):
status: New → Fix Committed
Changed in juju (Ubuntu Precise):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju - 0.5+bzr504-0ubuntu1

---------------
juju (0.5+bzr504-0ubuntu1) precise; urgency=low

  * New upstream snapshot (LP: #962507 LP: #953258 LP: #965507).
  * d/control: Depend and Build-Depend on python-oauth for MaaS.
  * d/control: Drop dummy ensemble package and make breaks/replaces
    broader to force removal of any ensemble package. (LP: #954492)
  * d/control: Move lxc, libvirt-bin, and zookeeper to Suggests to
    reduce the amount of packages installed on every node unecessarily
    and also avoid conflicting when deploying into a libvirt-bin
    default network VM (LP: #962389)
  * d/rules: skip test suite when nocheck is set.
  * d/rules: remove redundant dh_clean call
  * d/juju.install: remove usr, with only one binary package this is
    not necessary anymore and causes dh_install to fail because no
    files are installed to debian/tmp anymore.
  * d/rules,d/control,d/manpages,d/juju.manpages: Generate basic
    manpage from online help. (LP: #966611)
  * d/patches/no-write-sample-on-help.patch: Added so --help can be
    safely run without a writable home dir on buildds. (LP: #957682)
 -- Clint Byrum <email address hidden> Fri, 30 Mar 2012 15:28:16 -0700

Changed in juju (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers