juju.providers.orchestra.tests.test_digestauth fails with twisted 11.1

Bug #917954 reported by Clint Byrum
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pyjuju
Fix Released
Critical
Kapil Thangavelu
juju (Ubuntu)
Fix Released
Critical
Unassigned

Bug Description

  GetPageAuthHttpsTest
    test_404 ... CONNECTION(S) ALIVE! buggy test?
                                                          [OK]
    test_authenticate ... CONNECTION(S) ALIVE! buggy test?
                                              [ERROR]
    test_authenticate_postdata_201 ... CONNECTION(S) ALIVE! buggy test?
                                 [ERROR]
    test_authenticate_postdata_204 ... CONNECTION(S) ALIVE! buggy test?
                                 [ERROR]
    test_default_method ... CONNECTION(S) ALIVE! buggy test?
                                               [OK]
    test_other_method ... CONNECTION(S) ALIVE! buggy test?
                                                 [OK]

The full error log is here:

https://launchpadlibrarian.net/89795690/buildlog_ubuntu-precise-i386.juju_0.5%2Bbzr443-1juju2~precise1_FAILEDTOBUILD.txt.gz

In looking at this bug with Kapil, it became clear that there is some API change in twisted 11.1 that causes this, as the failure does not occur with twisted 11.0.

Tags: ftbfs

Related branches

Changed in juju:
importance: Undecided → Critical
assignee: nobody → Kapil Thangavelu (hazmat)
Changed in juju (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

this causes the package to fail since this fails the test suite

tags: added: ftbfs
Changed in juju:
milestone: none → florence
Changed in juju (Ubuntu):
milestone: none → ubuntu-12.04-beta-1
Changed in juju:
status: New → In Progress
Changed in juju:
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package juju - 0.5+bzr447-0ubuntu1

---------------
juju (0.5+bzr447-0ubuntu1) precise; urgency=low

  * d/control: Recommend components necessary for local provider except
    apt-cacher-ng, which is suggested. (LP: #873540) Also depend on tmux
    for debug-hooks and recommend byobu so the branding will be the same.
  * d/control: removing inaccurate Vcs-Bzr.
  * New upstream snapshot.
    - Fixed regression with twisted 11.1 (LP: #917954)
 -- Clint Byrum <email address hidden> Mon, 23 Jan 2012 10:16:55 -0800

Changed in juju (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers