juju set <service_name> --filename does not work

Bug #902143 reported by Nick Barcet
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pyjuju
Medium
Benjamin Saller

Bug Description

To the contrary of what 'juju set --help' the command 'juju set <service_name> --filename local.yaml' does not work. it errors out with "juju: error: unrecognized arguments: --filename".

Related branches

Changed in juju:
importance: Undecided → Medium
status: New → Confirmed
milestone: none → florence
Graham Binns (gmb)
Changed in juju:
status: Confirmed → In Progress
assignee: nobody → Graham Binns (gmb)
Revision history for this message
Graham Binns (gmb) wrote :

Assigning this to bcsaller as it appears he's already done the work.

Changed in juju:
assignee: Graham Binns (gmb) → Benjamin Saller (bcsaller)
Revision history for this message
Gustavo Niemeyer (niemeyer) wrote :

Graham, it sounds like you have a branch in the works fixing the same bug and was caught by the concurrency. Can you please push your branch for review and assign it to this bug as well? We can then see which branch is more evolved and pick it.

Thanks a for working on this.

Revision history for this message
Gustavo Niemeyer (niemeyer) wrote :

By the way, let's take the chance the option never worked and rename it to --config, as in deploy.

Changed in juju:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers