metadata.yaml needs a category / classifier field

Bug #890453 reported by Kapil Thangavelu
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pyjuju
Medium
Unassigned

Bug Description

As part facilitating the organization and display of charms within a charm store, it will be important to capture some category classifiers/tags for a charm. ie. database, proxy, etc and have them recorded by the charm author in metadata.yaml.

Changed in juju:
milestone: none → florence
importance: Undecided → Medium
Changed in juju:
milestone: florence → none
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Just recording my thoughts here, this needs to allow for *multiple* categories/classifications for charms. If we make it a single category system the "Other" category will grow indefinitely and the field will often be inaccurate.

Changed in juju:
status: New → Confirmed
Curtis Hovey (sinzui)
Changed in juju:
status: Confirmed → Triaged
Revision history for this message
Kapil Thangavelu (hazmat) wrote : Re: [Bug 890453] Re: metadata.yaml needs a category / classifier field

implemented in juju-core/charmworld.

On Fri, Oct 11, 2013 at 11:42 PM, Curtis Hovey <email address hidden> wrote:

> ** Changed in: juju
> Status: Confirmed => Triaged
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/890453
>
> Title:
> metadata.yaml needs a category / classifier field
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju/+bug/890453/+subscriptions
>

Changed in juju:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers