config options need a "file" type

Bug #814974 reported by Clint Byrum
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
juju-core
Low
Unassigned
pyjuju
Low
Unassigned

Bug Description

Many web apps have configurable options like "theme" or "logo image" which need to refer to a file. The best way to handle these would be to have a type: url which takes a local path or a remote url, which the *client* will fetch, and then upload to the ensemble environment and feed to the config hook as a url which it can use to pull the file's content.

Just having the hook accept the URL is not enough, the cool part is making it easy to put your logo on your blog without having to put it on img.ur or scp it anywhere.

Changed in ensemble:
milestone: none → dublin
Revision history for this message
Gustavo Niemeyer (niemeyer) wrote :

That's a nice feature we should add. I'm not sure if dublin is the right target, though.

Changed in ensemble:
milestone: dublin → none
Jim Baker (jimbaker)
Changed in juju:
milestone: none → florence
Changed in juju:
milestone: florence → none
importance: Undecided → Wishlist
milestone: none → florence
Jim Baker (jimbaker)
Changed in juju:
assignee: nobody → Jim Baker (jimbaker)
status: New → In Progress
Jim Baker (jimbaker)
Changed in juju:
status: In Progress → Triaged
Revision history for this message
Nick Barcet (nijaba) wrote :

This would be very useful as well for setting up https enable site where the certificate file need to reside on every unit of the service.

Using juju scp to each unit is the only workaround I could find right now, and it adds complexity to a simple juju-addunit.

Revision history for this message
Clint Byrum (clint-fewbar) wrote : Re: [Bug 814974] Re: config options need a "file" type

Excerpts from Nick Barcet's message of Fri Dec 09 12:43:35 UTC 2011:
> This would be very useful as well for setting up https enable site where
> the certificate file need to reside on every unit of the service.
>
> Using juju scp to each unit is the only workaround I could find right
> now, and it adds complexity to a simple juju-addunit.
>

Nick, agreed, this simplifies a lot of common tasks. The current work
around is to uuencode the file into a setting.

juju set cert=`uuencode file.pem` key=`uuencode file.key`

Would then be handled by config-changed by putting those in place as
the certs.

Note that ZK comms inside the network are unencrypted/unauthed, so
your key would be transmitted across the network in the clear, which is
probably a bad idea. In fact, I'm not sure juju is ready for secure work
until we sort the ZK issues in bug #804203.

Jim Baker (jimbaker)
Changed in juju:
status: Triaged → In Progress
Jim Baker (jimbaker)
Changed in juju:
status: In Progress → Triaged
assignee: Jim Baker (jimbaker) → nobody
Changed in juju:
milestone: florence → honolulu
Changed in juju:
milestone: honolulu → galapagos
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

This is a feature, not a bug. Moving to honolulu

Changed in juju:
milestone: galapagos → honolulu
Revision history for this message
Gustavo Niemeyer (niemeyer) wrote :

Can we leave that to the Go port? It will need a spec or at least some good
debate in either case to see how juju set args, deploy config file, etc,
will behave.

gustavo @ http://niemeyer.net
On May 2, 2012 3:41 PM, "Clint Byrum" <email address hidden> wrote:

> This is a feature, not a bug. Moving to honolulu
>
> ** Changed in: juju
> Milestone: galapagos => honolulu
>
> --
> You received this bug notification because you are a member of juju
> hackers, which is the registrant for juju.
> https://bugs.launchpad.net/bugs/814974
>
> Title:
> config options need a "file" type
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/juju/+bug/814974/+subscriptions
>

Changed in juju:
milestone: 0.6 → none
Curtis Hovey (sinzui)
Changed in juju:
importance: Wishlist → Low
tags: added: improvement
Curtis Hovey (sinzui)
Changed in juju-core:
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Jeff Pihach (hatch) wrote :

Any chance this is going to get some work done on it? Every charm I've worked on has needed this functionality in one way or another. It's quite a pain to always have to work around it one way or another.

Revision history for this message
Cheryl Jennings (cherylj) wrote :

Juju 2.0 introduces this as a concept called resources: https://jujucharms.com/docs/master/developer-resources

Changed in juju-core:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers