Juju LXC deployment fails with abort error

Bug #1201879 reported by Ameet Paranjape on 2013-07-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pyjuju
Undecided
Unassigned

Bug Description

Steps to recreate:
Follow the steps at https://juju.ubuntu.com/get-started/local/ to setup the .juju/environments.yaml file
juju bootstrap (this will finish successfully with the state server running)
juju deploy juju-gui (or any charm in the store)
  The lxc container stays stuck in the "pending" state
juju debug-log shows:
gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
lxc-create: failed to execute template 'ubuntu-cloud'
lxc-create: aborted

Expected Result:
The charm would start/run

I'm attaching the output of 'juju debug-log' console. I've already tried re-installing the package dependencies for LXC. as this deployment option was working for me just last week. Deployments to other environments like ec2 work fine.

Ameet Paranjape (ameetp) wrote :
Ameet Paranjape (ameetp) wrote :

When I removed the images in /var/cache/lxc/cloud-precise and did the steps again it worked. I must have corrupted them or the initial download was incomplete.

Anyway, this bug can be closed.

Changed in juju:
status: New → Invalid
Ameet Paranjape (ameetp) wrote :

Setting as invalid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers