Compile error

Bug #667169 reported by Andrei Vereha on 2010-10-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
PyJavaScriptCore
Undecided
Unassigned

Bug Description

When I run: python setup.py build I get:
Error converting Pyrex file to C:
------------------------------------------------------------
...
        else:
            return doubleVal
    elif jsType == kJSTypeString:
        jsStr = JSValueToStringCopy(jsCtx, jsValue, NULL)
        try:
            return PyUnicode_DecodeUTF16(JSStringGetCharactersPtr(jsStr),
                                                                ^
------------------------------------------------------------

/home/avereha/src/play/webkit/pyjavascriptcore/javascriptcore.pyx:133:65: Cannot assign type 'JSChar *' to 'Py_UNICODE *'

and the same error, different line:
/home/avereha/src/play/webkit/pyjavascriptcore/javascriptcore.pyx:174:57: Cannot assign type 'JSChar *' to 'Py_UNICODE *'

Workaround that worked for me: in python.pyi I changed the first parameter type to JSChar *. :)
0$python --version
Python 2.6.6
0$cython --version
Cython version 0.13

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers