Build fails on Ubuntu Karmic (and others)

Bug #523858 reported by dmoore on 2010-02-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pyexiv2
High
Mark Lee

Bug Description

Apparently some versions libboost-python have the suffix -mt appended, which causes the pyexiv2 scons build to fail. My own issues were on AMD64 version Ubuntu Karmic with default versions of dependencies.

Original report from the mailing list (see http://<email address hidden>/msg00015.html and follow up messages):

>> I had some troubles compiling on 64 Ubuntu Karmic. (I had no problems
>> compiling on 32 bit Jaunty.) All of my libboost* files in /usr/lib have a
>> suffix of "-mt" appended to them, so I edited src/SConscript and changed
>>
>> libs = ['boost_python', 'exiv2']
>>
>> to
>>
>> libs = ['boost_python-mt', 'exiv2']
>>
>> and then pyexiv2 compiles successfully. Hopefully there is a less hacky
>> fix than this...
>
> That's a known issue (although there is no bug report to track it, could you
> please file one?): the debian and ubuntu packages include a patch to work
> around it, see
> http://patch-tracker.debian.org/patch/series/view/pyexiv2/0.1.2-4/03_boost-lib-name
>
> Note that I remember reading somewhere that this -mt prefix was dropped in
> newer versions of packages (can't find the link now), and it seems to be the
> case in ubuntu karmic: libboost-python1.38.0 has the -mt prefix,
> libboost-python1.40.0 doesn't (compare
> http://packages.ubuntu.com/karmic/amd64/libboost-python1.38.0/filelist to
> http://packages.ubuntu.com/karmic/amd64/libboost-python1.40.0/filelist).
>

Olivier Tilloy (osomon) wrote :
Changed in pyexiv2:
importance: Undecided → High
status: New → Confirmed
tags: added: build
Olivier Tilloy (osomon) wrote :

This is an excerpt from the NEWS.Debian file in the package for libboost-python 1.39.0-1:

Boost 1.39.0-1
--------------

  * Since only one (the multi-threaded) variant of each library is built,
    upstream elected to simplify the library name by removing the
    redundant "-mt" decoration. Debian will follow this convention, to
    remain compatible at link time with other vendors. The preferred form
    of the link option is now "-lboost_regex", etc.

  * In response to the Debian 1.37 package, a number of boost-using
    packages changed their build system to add "-mt"; see entry below. To
    avoid breaking all these packages, Debian is providing compatibility
    symlinks with the "-mt" decoration; e.g. "-lboost_regex-mt" continues
    to work. However, note that this name is not compatible with other
    distributions, so build-system authors are encouraged to use the
    undecorated name.

Mark Lee (malept) wrote :

For what it's worth, I also made a small change to the scons file, but it supports both library configurations. I've linked the branch to this bug.

Olivier Tilloy (osomon) wrote :

Thanks for the patch Mark, I like how it allows to specify a custom name for the boost::python library while still defaulting to boost_python. I merged it in revision 278.

Changed in pyexiv2:
assignee: nobody → Mark Lee (malept)
milestone: none → 0.2
status: Confirmed → Fix Committed
Olivier Tilloy (osomon) on 2010-03-25
Changed in pyexiv2:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers