Segmentation fault when exiting python after importing pyexiv2

Bug #1050918 reported by Nick Hall on 2012-09-14
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pyexiv2
High
Unassigned
pyexiv2 (Ubuntu)
Undecided
Unassigned

Bug Description

Using Ubuntu 12.10 beta1 and pyexiv2 0.3.2 I get a segmentation fault when exiting python.

To reporoduce:

python -c 'import pyexiv2'

I got the following backtrace using gdb:

Program received signal SIGSEGV, Segmentation fault.
0x080ea5b7 in tupledealloc.24618 (op=0x834e194) at ../Objects/tupleobject.c:218
218 ../Objects/tupleobject.c: No such file or directory.
(gdb) bt
#0 0x080ea5b7 in tupledealloc.24618 (op=0x834e194)
    at ../Objects/tupleobject.c:218
#1 0xb7afe2a7 in boost::python::tuple::~tuple() ()
   from /usr/lib/python2.7/dist-packages/libexiv2python.so
#2 0xb7e17f41 in __run_exit_handlers (status=0, listp=
    0xb7f863e4 <__exit_funcs>, run_list_atexit=true) at exit.c:78
#3 0xb7e17fcd in __GI_exit (status=0) at exit.c:100
#4 0xb7dfe4db in __libc_start_main (main=0x808f8d9 <main>, argc=2, ubp_av=
    0xbffff374, init=0x8169d80 <__libc_csu_init>, fini=
    0x8169df0 <__libc_csu_fini>, rtld_fini=0xb7fed270 <_dl_fini>, stack_end=
    0xbffff36c) at libc-start.c:258
#5 0x0810c4e5 in _start ()

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue and making Ubuntu better.

I also get a segmentation fault on Quantal when following your steps to reproduce.

Changed in pyexiv2 (Ubuntu):
status: New → Confirmed
summary: - Segmentaion fault when exiting python
+ Segmentation fault when exiting python after importing pyexiv2
tags: added: quantal
Olivier Tilloy (osomon) wrote :

I can also reproduce with the tip of the trunk on Quantal.

Changed in pyexiv2:
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

For some reason, instantiating the exiv2_version tuple outside of the boost module declaration causes the segfault, whereas it previously worked. This is easily fixed by moving the instantiation inside the BOOST_PYTHON_MODULE block.

Changed in pyexiv2:
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :

Fixed in the trunk at revision 376.

Changed in pyexiv2:
status: In Progress → Fix Committed
Nick Hall (n-hall) wrote :

Thanks. The problem is now fixed. When can we expect an updated package?

Olivier Tilloy (osomon) wrote :

I just subscribed Micah and Martin-Éric who helped with packaging issues in the past.
Guys, could we have the patch that fixes this bug pushed to Quantal? For convenience I’m attaching it here (it’s the contents of revision 376 of lp:pyexiv2).
Thanks!

The attachment "version-tuple.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Matthias Klose (doko) on 2012-09-26
Changed in pyexiv2 (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyexiv2 - 0.3.2-5ubuntu1

---------------
pyexiv2 (0.3.2-5ubuntu1) quantal; urgency=low

  * Fix build failure (Olivier Tilloy). LP: #1050918.
 -- Matthias Klose <email address hidden> Wed, 26 Sep 2012 16:05:33 +0200

Changed in pyexiv2 (Ubuntu):
status: Fix Committed → Fix Released
Olivier Tilloy (osomon) on 2014-10-24
Changed in pyexiv2:
assignee: Olivier Tilloy (osomon) → nobody

Hello, I tried a no-change rebuild without this patch, and also a build of pyexiv2 0.3.2-9 from Debian, and none of them had this issue
"python -c 'import pyexiv2'"

works with and without this patch. For this reason, I'm going to sync pyexiv2 from Debian, since this was the only remaining delta.

I suspect this was some sort of python regression that has been fixed in the meanwhile?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers