easier way to resolve dependencies?

Bug #805676 reported by smithson on 2011-07-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Purple
Undecided
Unassigned

Bug Description

% pip install "http://launchpad.net/purple/trunk/11.03.2/+download/purple_11.03.2.tar.gz"
Downloading/unpacking http://launchpad.net/purple/trunk/11.03.2/+download/purple_11.03.2.tar.gz
  Downloading purple_11.03.2.tar.gz
  Running setup.py egg_info for package from http://launchpad.net/purple/trunk/11.03.2/+download/purple_11.03.2.tar.gz
    ERROR: Python module simplejson not found
    ERROR: Python module storm not found
    ERROR: Python module dbus not found
    ERROR: Python module dbus.service not found
    ERROR: Python module dbus.mainloop.glib not found
    ERROR: Python module gtk not found
    ERROR: Python module dbus not found
    ERROR: Python module gobject not found
    ERROR: Python module LaunchpadIntegration not found
    ERROR: Python module gtk not found
    ERROR: Python module pango not found
    ERROR: Python module storm.locals not found
    ERROR: Python module glib not found
    ERROR: Python module gio not found
    ERROR: Python module apport not found
    ERROR: Python module gtk not found
    ERROR: Python module gtk not found
    ERROR: Python module gtk not found

    WARNING: the following files are not recognized by DistUtilsExtra.auto:
      bin/purple
      po/purple.pot
      purple.desktop.in
Installing collected packages: purple
  Running setup.py install for purple
    ERROR: Python module simplejson not found
    ERROR: Python module storm not found
    ERROR: Python module dbus not found
    ERROR: Python module dbus.service not found
    ERROR: Python module dbus.mainloop.glib not found
    ERROR: Python module gtk not found
    ERROR: Python module pango not found
    ERROR: Python module storm.locals not found
    ERROR: Python module glib not found
    ERROR: Python module gio not found
    ERROR: Python module apport not found
    ERROR: Python module gtk not found
    ERROR: Python module gtk not found
    ERROR: Python module gtk not found
    ERROR: Python module dbus not found
    ERROR: Python module gobject not found
    ERROR: Python module LaunchpadIntegration not found
    ERROR: Python module gtk not found
    usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
       or: -c --help [cmd1 cmd2 ...]
       or: -c --help-commands
       or: -c cmd --help

    error: option --single-version-externally-managed not recognized
    Complete output from command /usr/local/bin/python -c "import setuptools;__file__='/var/folders/MT/MTdESo89GBCaGM7Hevp5+E+++TI/-Tmp-/pip-6Q5hcr-build/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --single-version-externally-managed --record /var/folders/MT/MTdESo89GBCaGM7Hevp5+E+++TI/-Tmp-/pip-CwLFAs-record/install-record.txt:
    ERROR: Python module simplejson not found

ERROR: Python module storm not found

ERROR: Python module dbus not found

ERROR: Python module dbus.service not found

ERROR: Python module dbus.mainloop.glib not found

ERROR: Python module gtk not found

ERROR: Python module pango not found

ERROR: Python module storm.locals not found

ERROR: Python module glib not found

ERROR: Python module gio not found

ERROR: Python module apport not found

ERROR: Python module gtk not found

ERROR: Python module gtk not found

ERROR: Python module gtk not found

ERROR: Python module dbus not found

ERROR: Python module gobject not found

ERROR: Python module LaunchpadIntegration not found

ERROR: Python module gtk not found

usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]

   or: -c --help [cmd1 cmd2 ...]

   or: -c --help-commands

   or: -c cmd --help

error: option --single-version-externally-managed not recognized

----------------------------------------
Command /usr/local/bin/python -c "import setuptools;__file__='/var/folders/MT/MTdESo89GBCaGM7Hevp5+E+++TI/-Tmp-/pip-6Q5hcr-build/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --single-version-externally-managed --record /var/folders/MT/MTdESo89GBCaGM7Hevp5+E+++TI/-Tmp-/pip-CwLFAs-record/install-record.txt failed with error code 1
Storing complete log in /Users/jw/.pip/pip.log

Avi Romanoff (aroman) wrote :

I'm not sure what the bug is, i'm not sure why you're installing via pip, and I'm also not maintaining or updating Purple any more.

Rather, I'm in the final phases of finishing Lingo, which is essentially Purple written in Vala. It's completely backwards compatible and will upgrade gracefully.

Changed in purple:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for Purple because there has been no activity for 60 days.]

Changed in purple:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers