Can't run x apps in latest rc image

Bug #1642529 reported by Victor gonzalez
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Stephen M. Webb
Libertine
Undecided
Unassigned
Puritine
Undecided
Unassigned
ubuntu-app-launch (Ubuntu)
Undecided
Unassigned

Bug Description

Environment:

current build number: 21
device name: frieza
channel: ubuntu-touch/rc/bq-aquaris-pd.en
last update: 2016-11-17 09:25:37
version version: 21
version ubuntu: 20161116
version device: 20160809.0
version custom: 20160831--42-26-vivid

Steps to reproduce:

1º Go to desktop apps scope
2º Try to open a desktop app

Current result: they all crash and unity8 log reports:

** (process:2298): CRITICAL **: Error parsing manifest for package 'puritine': puritine does not exist in any database for user phablet
--> https://pastebin.canonical.com/170951/

Expected result: all desktop apps should work

Add info: no crash files found,time stamp 10:14, logs attached

Revision history for this message
Victor gonzalez (victor-gonzalez-0) wrote :
description: updated
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

From the logs:

$ cat application-legacy-puritine_gedit_0.0-.log
usage: libertine-launch [-h] container_id ...
libertine-launch: error: unrecognized arguments: --id=puritine

Changed in canonical-devices-system-image:
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → Stephen M. Webb (bregma)
milestone: none → 14
Revision history for this message
Stephen M. Webb (bregma) wrote :

Evidently a newer ubuntu-app-launch package mismatches with the older libertine-tools package. Probably need to backport the latest Libertine package to vivid.

Revision history for this message
Christopher Townsend (townsend) wrote :

Most definitely not an issue in Puritine itself, so marking that invalid.

Looking at the log, it seems an older version of libertine is in this image. Could you provide the output of 'apt-cache policy libertine-tools'?

The version of libertine in vivid overlay is 1.4.2+15.04.20161005-0ubuntu1.

Changed in puritine:
status: New → Invalid
Changed in libertine:
status: New → Incomplete
Revision history for this message
Victor gonzalez (victor-gonzalez-0) wrote :

@townsend, hi I'm getting this output:

Installed: 1.4+15.04.20160908-0ubuntu1
  Candidate: 1.4+15.04.20160908-0ubuntu1
  Version table:
 *** 1.4+15.04.20160908-0ubuntu1 0
        100 /var/lib/dpkg/status

Revision history for this message
Christopher Townsend (townsend) wrote :

Thanks! So not a libertine bug. The image needs to include the correct version of libertine-tools.

Changed in libertine:
status: Incomplete → Invalid
Changed in ubuntu-app-launch (Ubuntu):
status: New → Invalid
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments