Amsynth crashes while loading

Bug #529858 reported by Grant Centauri on 2010-03-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Puredyne Live
High
krgn

Bug Description

This is what I get when trying to launch amsynth from command line:

amSynth 1.2.0
Copyright 2001-2006 Nick Dowell and others.
amSynth comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
cannot load JACK library
ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
ALSA: cannot open audio device default
ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
ALSA: cannot open audio device default
<OSSAudioDriver> error: could not open dsp device /dev/dsp
error: could not find "auto" audio driver
*** buffer overflow detected ***: amsynth terminated

then on the very bottom of a list of various .so files i get this:

0364a000-03650000 r-xp 00000000 00:10 158 /lib/tls/i686/cmov/libnss_compat-2.10.1.so
03650000-03651000 r--p 00005000 00:10 158 /lib/tls/i686/cmov/libnss_compat-2.10.1.so
03651000-03652000 rw-p 00006000 00:10 158 /lib/tls/i686/cmov/libnss_compat-2.10.1.so
0403e000-04082000 r-xp 00000000 00:10 1614 /usr/lib/libpixman-1.so.0.14.0
04082000-04084000 r--p 00043000 00:10 1614 /usr/lib/libpixman-1.so.0.14.0
04084000-04085000 rw-p 00045000 00:10 1614 /usr/lib/libpixman-1.so.0.14.0zsh: abort amsynth

krgn (karsten-goto10) wrote :

an updated version of amsynth is now in our ppa, please test it. for it has been working now.

Changed in puredyne-live:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → krgn (karsten-goto10)
milestone: none → 9.11
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers