Puredyne liveCD/DVD/USB/HD

liveUSB keys do not boot on Mactels

Reported by Aymeric Mansoux on 2010-01-17
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Puredyne Live
Critical
Unassigned

Bug Description

They just don't:

 1) Why?
 2) How do we solve this once and for all?

Changed in puredyne-live:
status: New → Confirmed
importance: Undecided → Critical
danstowell (danstowell) wrote :

Can we have more info please?

* Does it affect all mactels? Which have we tested?
* Does it depend whether rEFIt is installed? http://refit.sourceforge.net/
(Allegedly you can do it without refit, by holding option on boot)

At work I have a mactel from 2006 with rEFIt installed, and it happily recognises and boots the CD/DVD but not the USB - the volume appears in the rEFIt menu but with some generic label like "unallocated" or something. (Will add info about the machine when I'm next at work.)

Slax used to publish a "USB boot CD" which would pass control over to the USB on machines that didn't directly support USB boot. (Seems like they don't do this any more?)

Aymeric Mansoux (aymeric) wrote :

I think CD/DVD boot does not need CD but just hitting "c" at startup should be enough, no?

Regarding the USB boot CD, this can be done too in Puredyne. In fact you just need to pass an extra boot argument from the isolinux prompt when the CD/DVD is booting. Something like "from=/dev/sdb1" (or "live-media=/dev/sdb1") and it will use the USB device as live medium.

If you do not do this, but just boot from the CD/DVD with the key inserted and the default options, the persitence will work and the changes will be recorded on the key, just like usual.

Aymeric Mansoux (aymeric) wrote :

"I think CD/DVD boot does not need CD [...]"

I meant "I think CD/DVD boot does not need rEFIt [...]"

Changed in puredyne-live:
milestone: none → 10.04
Aymeric Mansoux (aymeric) wrote :

update:

I managed to get a booting Puredyne liveUSB with this:
 * create a 32MB FAT32 primary partition on the key
 * copy the attached folder in it (it contain efi drivers and grub2 config)
 * Make a following partition with the usual live folder (took the one from an existing working Puredyne liveUSB)

Live kernel and initrd are loading fine but the macbook I'm testing it on has a linux partition that seems to make live-initramfs confused, I need to find someone with a standard macbook to properly test.

Aymeric Mansoux (aymeric) wrote :
c.cobb (chris-a-cobb) wrote :

I would really like to help test this. Not sure what a "standard" mackbook is, but I have a white model that has a 2.1GHz Intel Core 2 Duo.

I've been having many problems creating a USB that is bootable by my older PC, but booting Ubuntu on this macbook works really well. After long searching, I ran across a post with an EFI boot subdir tar file attached, but different from yours. That one had three files: bootx64.efi, bootx64.icns, and the grub.cfg. All I did was to copy these into a /efi/boot subdir (on a 2GB stick with a single FAT32 partition), and voila, the USB was recognized on the Mac when I booted holding the option key. And no, I did not install rEFIt.

Until I screwed up yet another USB stick, I was successfully booting Ubuntu on my MacBook and my PC from the same stick, so I know that this is possible. I am trying to get this working again! Still haven't solved my LiveUSB stick creation problems on the PC, and was hoping that maybe your "make_live_device.sh" script would help point me in the right direction.

After the USB stick booted Ubuntu on my MacBook, I tried it on my neighbor's MacBook Pro but without success. The grub menu came up, but after that it just hung there. Seems to take a long time to boot on my Mac, so maybe I just didn't wait long enough?

Let me know what I can do to help. Simply install PureDyne and try creating a USB? or something else?

c.cobb (chris-a-cobb) wrote :

Never mind, it's booting again on both PC and MacBook.

But thanks for your note about the 32MB partition...I don't need the little partition, but I do need to ensure that both the syslinux stage 2 and the efi subdir are copied first to make sure they're in the first 32MB on the stick.

Aymeric Mansoux (aymeric) wrote :

Hi there,

Thanks for the feedback!

would you mind describing a step-by-step HOWTO to get the stick working both on Mac and PC? Reading your notes I am a bit confused on how you managed to do it, am I correct to think that such a key as both syslinux and grub2 installed (syslinux as default boot manager grub files in the efi/boot folder) ?

c.cobb (chris-a-cobb) wrote :

Yes, that's right: syslinux installed into the MBR, and grub2 w/EFI installed in \efi\boot\ subdir.

After installing the latest version of syslinux, all of my booting problems went away. No more 32MB limits, and everything just works on both Wintel and Mactel.

Details and demos are here: http://ccobb.net/demos/liveusb/

Grant Centauri (gcentauri) wrote :

I'd like to help out with this as well. I've got access to a recent MacBook pro. The last time I tried was about a month ago and I also had issues with the initramfs. Other than that it seems that the EFI booting works fine as long as its on a vfat partition. I am also trying to figure this out with a custom debian-live build. It would be nice to find a general solution for booting a live-usb on Mactel, but not sure how realistic that is.

Grant Centauri (gcentauri) wrote :

Just tested gazpacho installed on a USB with a FAT32 system partition, GRUB2 installed to the MBR, and an /efi/boot subdirectory with c.cobb's grub.cfg files.

booting on PC worked fine, but the iMac I am testing it on won't even recognize the device to boot from it. It may have something to do with the version of EFI installed? it is the iMac EFI firmware version 1.2

this could add extra problems, as older macs may not be able to boot without a firmware update. i am tempted to update it and try again, but this is not my machine and i probably shouldn't be unilaterally deciding to update the firmware.

Grant Centauri (gcentauri) wrote :

after looking some more, it seems like EFI v1.2 is the latest this Mac can get? i'm stumped here. going to wait and test on Macbook Pro later and see what happens.

Aymeric Mansoux (aymeric) wrote :

Without a mac to test and no clear instruction on how to have a bootable key for mac, it's impossible to fix the script. I mark as incomplete for now..

Changed in puredyne-live:
status: Confirmed → Incomplete
Pete (beeblepete) wrote :

Please ignore this if I'm not helping (I'm no expert) but I didn't see any mention here of the requirement that bootable Mac volumes use the GUID partition scheme. Details:

http://support.apple.com/kb/HT1948

A savvy Puredyner might hop into a thread over there and ask better questions than I could.

In case it helps, here's my naive GUI-based GUID instruction:

- Applications > Utilities > Disk Utility.app
- Select the USB device in sidebar (not a volume of a device)
- Go to the Partition tab

An Options button will be available when first partitioning (or re-partitioning) the device. GUID is a choice in there.

Leon-Geyer (leon-geyer) wrote :

I am looking for an universal USB, = a persistent USB-Drive which can boot on any computer, without preparing it. And an universal CD. I found this link: http://ubuntuforums.org/showthread.php?t=1065670. Is it of any use for pure dyne?

Abraham Levine (alevine) wrote :

Macs are incapable of booting from any USB.

Leon-Geyer (leon-geyer) wrote :

It seems to me that this general affirmation can't be true, as far as I have seen in my years of Mac-User.
Starting from an external USB storage device (Intel-based Macs)
http://support.apple.com/kb/ht1948

poischiche (yuu-bg) wrote :

I hope this can help : Framasoft success to have a key which but on an intel mac (but with refit installed on mac or with a MBR formatted mac) and a pc (but it was not booting on some thin client pc...). It was the Framakey with some open soft... & it was using isolinux or extlinux...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers