jack issues with FireWire soundcards

Bug #506064 reported by yvan volochine on 2010-01-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Puredyne Live
High
Unassigned

Bug Description

Firewire soundcards don't work with jack and latest dev iso (from 9 januar).

-running qjackctl with freebob driver (and basic settings) gives:
"Ieee1394Service::initialize: Could not get 1394 handle: Invalid argument
Is ieee1394 and raw1394 driver loaded?"

-running it with firewire driver is a non-go:
"firewire ERR: Error creating FFADO streaming device
cannot load driver module firewire"

-running qjackctl as root with freebob gives me an xrun every 2 seconds

I have the same issues running jackd from command-line.

My jack settings are basic:
/usr/bin/jackd -P 70 -R -P89 -dfreebob -dhw:0 -r44100 -p1024 -n3 -D

My soundcard is a Presonus Firebox which used to run fine on Leek And Potato (and Miso Soup) if jack and all depending audio apps were run as root.

Aymeric Mansoux (aymeric) wrote :

did you use the same settings both in L&P/Miso and C&C?

did you try with different JACK settings?

Changed in puredyne-live:
status: New → Incomplete
importance: Undecided → High
yaxu (alex-slab) wrote :

For me, this works if run as root:
  jackd -d firewire

If run as normal user I get the same error:
"firewire ERR: Error creating FFADO streaming device
cannot load driver module firewire"

yaxu (alex-slab) wrote :

starting qjackctl as root (sudo qjackctl) also works

yaxu (alex-slab) wrote :

Sorry about all the comments.

I think the problem is /dev/raw1394 is group disk, set in /etc/udev/rules.d/40-permissions.rules , which standard users aren't a member of.
If I add myself to the disk group and re-login, I don't have to run jackd as root anymore.

Aymeric Mansoux (aymeric) wrote :

fixed in r316.

Will be available in bugfix release 9.11 :)

Changed in puredyne-live:
status: Incomplete → Fix Committed
yvan volochine (elgusanorojo) wrote :

hi
indeed, I don't have to start jack as root anymore with 9.11, but the xruns issue is still the same (with whatever settings I use, I have a lot of xruns).
I tried with 2, 3, 4 buffers (512, 1024 or 2048), same problem.
also tried with "memlock unlimited", same again.

any hints are very welcome!

aleij (alejoduque) wrote :

i have installed ffado-debus-server, then qjackctl is able to create the firewire streaming device via ffado.
both ran as root under c&c 910.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers