lack of authkey for pacemaker at compute nodes

Bug #1850058 reported by Nikita Belov on 2019-10-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
puppet-pacemaker
Undecided
Unassigned
tripleo
Undecided
Mihai Plasoianu

Bug Description

I try to deploy overcloud with tripleo (train release). At config deploy stage I'm getting an error with pcs status because I don't have authkey at compute nodes:
Error: cluster is not currently running on this node
pcs status ... returned 1 instead of one of [0]

If I copy key from controller, do enable pacemaker_remote and start pacemaker_remote I can continue deploy without pcs status error.

Revision history for this message
MiP (mihaiplasoianu) wrote :
Revision history for this message
MiP (mihaiplasoianu) wrote :

This should only happen on CentOS(/RHEL) < 8

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-tripleo (master)

Fix proposed to branch: master
Review: https://review.opendev.org/713689

Changed in tripleo:
assignee: nobody → Mihai Plasoianu (m1p)
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-tripleo (stable/train)

Fix proposed to branch: stable/train
Review: https://review.opendev.org/714107

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-tripleo (master)

Change abandoned by Mihai Plasoianu (<email address hidden>) on branch: master
Review: https://review.opendev.org/713689
Reason: This is being handled here: I9b04c1bb5a2389201b99815f17d6242baaf856d9

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-tripleo (stable/train)

Reviewed: https://review.opendev.org/714107
Committed: https://git.openstack.org/cgit/openstack/puppet-tripleo/commit/?id=91627ee5fcc8abd58830544d1846857e860c11b8
Submitter: Zuul
Branch: stable/train

commit 91627ee5fcc8abd58830544d1846857e860c11b8
Author: Mihai Plasoianu <email address hidden>
Date: Fri Mar 20 14:17:49 2020 +0100

    pacemaker-remote is broken on CentOS/RHEL < 8

    Broken since commit 16c5f1692580d7fc42985d8895828eb71433af09
    The problem is when setting use_pcsd to true, the new
    pcs 0.10 remote addition is always used, which doesn't work
    on CentOS/RHEL before 8.

    Change-Id: I9b04c1bb5a2389201b99815f17d6242baaf856d9
    Closes-bug: #1850058

tags: added: in-stable-train
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-tripleo 11.5.0

This issue was fixed in the openstack/puppet-tripleo 11.5.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers