beaker/centos7: impossible to install rdo packages

Bug #1470685 reported by Emilien Macchi
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet-openstack
Invalid
Critical
Unassigned

Bug Description

Stage[main]/Keystone/Package[keystone]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Delta RPMs disabled because /usr/bin/applydeltarpm not installed.

http://logs.openstack.org/97/197797/1/check/gate-puppet-designate-puppet-beaker-rspec-dsvm-centos7/26b131f/console.html#_2015-07-02_01_24_14_098

Running this issue everywhere for all beaker jobs on centos7.

Changed in puppet-openstack:
status: New → Confirmed
importance: Undecided → Critical
Revision history for this message
Alan Pevec (apevec) wrote :

I could not reproduce on clean centos7: http://paste.openstack.org/show/335147/
1.install requests from base EL7
2. update to version from RDO Kilo worked w/o issues

Where can I get centos7 image used in puppet-beaker jobs?

Revision history for this message
Alan Pevec (apevec) wrote :

mmagr provided me access to the base centos7 image used by the job and it looks like requests was pypi installed hence issues on rpm upgrade. Excerpt from rpm -Va output:
...
missing /usr/lib/python2.7/site-packages/requests-1.1.0-py2.7.egg-info
S.5....T. /usr/lib/python2.7/site-packages/requests/__init__.py
S.5....T. /usr/lib/python2.7/site-packages/requests/__init__.pyc
S.5....T. /usr/lib/python2.7/site-packages/requests/__init__.pyo
...

Revision history for this message
Emilien Macchi (emilienm) wrote :

I close the bug, the centos image is good now, thanks to https://review.openstack.org/#/c/198082.

Changed in puppet-openstack:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers