oga requires Ruby version >= 2.4

Bug #1854905 reported by zhongshengping on 2019-12-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
puppet-openstack-spec-helper
Status tracked in Train
Queens
High
zhongshengping
Rocky
High
zhongshengping
Stein
High
zhongshengping
Train
High
zhongshengping

Bug Description

2019-12-03 07:00:43.096139 | centos-7 | Installing oga 3.0 with native extensions
2019-12-03 07:00:43.130264 | centos-7 | Gem::InstallError: oga requires Ruby version >= 2.3.0.
2019-12-03 07:00:43.130408 | centos-7 | An error occurred while installing oga (3.0), and Bundler cannot continue.
2019-12-03 07:00:43.130509 | centos-7 | Make sure that `gem install oga -v '3.0' --source 'https://rubygems.org/'`
2019-12-03 07:00:43.130560 | centos-7 | succeeds before bundling.
2019-12-03 07:00:43.130586 | centos-7 |
2019-12-03 07:00:43.130624 | centos-7 | In Gemfile:
2019-12-03 07:00:43.130742 | centos-7 | puppet-openstack_spec_helper was resolved to 16.0.0, which depends on
2019-12-03 07:00:43.130844 | centos-7 | beaker-puppet was resolved to 0.17.1, which depends on
2019-12-03 07:00:43.130885 | centos-7 | oga

zhongshengping (chdzsp) on 2019-12-03
Changed in puppet-openstack-spec-helper:
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → zhongshengping (chdzsp)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers