CentOS 8 Integration/Litmus jobs are broken because of conflicting package requirement

Bug #1966848 reported by Takashi Kajinami
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet-openstack-integration
Fix Released
Critical
Takashi Kajinami

Bug Description

The centos-gpg-keys-8-5.el8.noarch.rpm package was recently released to the extras repo,
but this broken package update during integration job and litmus job.

https://zuul.opendev.org/t/openstack/build/0d745f587a0d469485a8124593be00cf/log/logs/puppet.txt#60-64
~~~
Problem: package centos-stream-repos-8-4.el8.noarch requires centos-gpg-keys = 1:8-4.el8, but none of the providers can be installed
 - cannot install both centos-gpg-keys-1:8-5.el8.noarch and centos-gpg-keys-1:8-4.el8.noarch
 - cannot install the best update candidate for package centos-stream-repos-8-4.el8.noarch
 - cannot install the best update candidate for package centos-gpg-keys-1:8-4.el8.noarch
~~~

Changed in puppet-openstack-integration:
importance: Undecided → Critical
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-openstack-integration (master)
Changed in puppet-openstack-integration:
status: New → In Progress
Changed in puppet-openstack-integration:
assignee: nobody → Takashi Kajinami (kajinamit)
Revision history for this message
Tobias Urdin (tobias-urdin) wrote :
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-openstack-integration (master)

Change abandoned by "Takashi Kajinami <email address hidden>" on branch: master
Review: https://review.opendev.org/c/openstack/puppet-openstack-integration/+/835535

Revision history for this message
Takashi Kajinami (kajinamit) wrote :

The new package was released and it solved the issue.

Changed in puppet-openstack-integration:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers