r10k installation fails with fast_gettext requires Ruby version >= 2.1.0

Bug #1609081 reported by David Moreau Simard on 2016-08-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet-openstack-integration
Undecided
David Moreau Simard
puppet-openstack-spec-helper
Undecided
Cody Herriges

Bug Description

It is currently not possible to install r10k on EL7, installation fails with an error:

Gem::InstallError: fast_gettext requires Ruby version >= 2.1.0.

Example: http://logs.openstack.org/89/350189/1/check/gate-puppet-openstack-integration-puppet-syntax-3-centos-7/959157b/console.html#_2016-08-02_18_05_47_844133

Cody Herriges (ody-cat) on 2016-08-02
Changed in puppet-openstack-spec-helper:
assignee: nobody → Cody Herriges (ody-cat)
Changed in puppet-openstack-integration:
assignee: nobody → David Moreau Simard (dmsimard)
Cody Herriges (ody-cat) wrote :

While we rushed to find a workaround, this got fixed and released upstream.

Changed in puppet-openstack-spec-helper:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers