latest puppet expects catalog to contain resources to for requires and subscribes

Bug #1702964 reported by Alex Schultz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet-aodh
High
zhongshengping
puppet-barbican
High
zhongshengping
puppet-ceilometer
High
zhongshengping
puppet-ceph
Medium
Alex Schultz
puppet-cinder
Medium
Alex Schultz
puppet-designate
Medium
zhongshengping
puppet-glance
High
zhongshengping
puppet-gnocchi
High
zhongshengping
puppet-ironic
Medium
zhongshengping
puppet-keystone
Medium
Alex Schultz
puppet-manila
Medium
Alex Schultz
puppet-mistral
High
zhongshengping
puppet-neutron
Medium
Alex Schultz
puppet-nova
Medium
Alex Schultz
puppet-openstacklib
Medium
zhongshengping
puppet-panko
High
zhongshengping
puppet-swift
Medium
Alex Schultz
puppet-vitrage
High
zhongshengping
tripleo
Medium
Emilien Macchi

Bug Description

The unit tests for puppet 5 (running via latest) is failing on some modules because the catalog created in the test doesn't contain the resources being referenced in requires/subscribes. For example:

http://logs.openstack.org/70/480170/1/check/gate-puppet-ceph-puppet-unit-latest-centos-7/b26b6f1/console.html#_2017-07-04_12_56_43_698263
Could not find resource 'Class[Ceph]' in parameter 'require' at /home/jenkins/workspace/gate-puppet-ceph-puppet-unit-latest-centos-7/spec/fixtures/modules/ceph/manifests/key.pp:174 on node centos-7-rax-ord-9642162

This can be fixed by switching to anchors (with an include) or using a pre_condition in the tests to ensure the correct classes are includes. For most of the puppet-openstack modules we should be using the anchors provided by <class>::deps rather than referencing the actual package/service. For classes without a deps class, we may just need to use a pre_condition in the test to include the appropriate resources.

Changed in tripleo:
status: New → Triaged
importance: Undecided → Medium
milestone: none → queens-1
Changed in puppet-swift:
importance: Undecided → Medium
Changed in puppet-openstacklib:
importance: Undecided → Medium
Changed in puppet-nova:
importance: Undecided → Medium
Changed in puppet-neutron:
importance: Undecided → Medium
Changed in puppet-manila:
importance: Undecided → Medium
Changed in puppet-keystone:
importance: Undecided → Medium
Changed in puppet-cinder:
importance: Undecided → Medium
Changed in puppet-ceph:
importance: Undecided → Medium
Changed in puppet-swift:
status: New → Confirmed
Changed in puppet-openstacklib:
status: New → Confirmed
Changed in puppet-nova:
status: New → Confirmed
Changed in puppet-neutron:
status: New → Confirmed
Changed in puppet-manila:
status: New → Confirmed
Changed in puppet-keystone:
status: New → Confirmed
Changed in puppet-cinder:
status: New → Confirmed
Changed in puppet-ceph:
status: New → Confirmed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ceph (master)

Fix proposed to branch: master
Review: https://review.openstack.org/481749

Changed in puppet-ceph:
assignee: nobody → Alex Schultz (alex-schultz)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-cinder (master)

Fix proposed to branch: master
Review: https://review.openstack.org/481753

Changed in puppet-cinder:
assignee: nobody → Alex Schultz (alex-schultz)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-keystone (master)

Fix proposed to branch: master
Review: https://review.openstack.org/481759

Changed in puppet-keystone:
assignee: nobody → Alex Schultz (alex-schultz)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-manila (master)

Fix proposed to branch: master
Review: https://review.openstack.org/481761

Changed in puppet-manila:
assignee: nobody → Alex Schultz (alex-schultz)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-neutron (master)

Fix proposed to branch: master
Review: https://review.openstack.org/481767

Changed in puppet-neutron:
assignee: nobody → Alex Schultz (alex-schultz)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-ceph (master)

Reviewed: https://review.openstack.org/481749
Committed: https://git.openstack.org/cgit/openstack/puppet-ceph/commit/?id=69b651ff4c061becf556b7b8443ffb160c6f6f39
Submitter: Jenkins
Branch: master

commit 69b651ff4c061becf556b7b8443ffb160c6f6f39
Author: Alex Schultz <email address hidden>
Date: Fri Jul 7 14:18:37 2017 -0600

    Fix tests for latest puppet

    Adding in a pre condition for the ceph key tests to resolve catalog
    failures in the unit tests under the latest version of puppet.

    Change-Id: Ie56f77c8ff841785e083e84c3d22eac9a5b64d75
    Closes-Bug: #1702964

Changed in puppet-ceph:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-cinder (master)

Reviewed: https://review.openstack.org/481753
Committed: https://git.openstack.org/cgit/openstack/puppet-cinder/commit/?id=02b35294a599bb714f1cae630aa1bf0bb40a237b
Submitter: Jenkins
Branch: master

commit 02b35294a599bb714f1cae630aa1bf0bb40a237b
Author: Alex Schultz <email address hidden>
Date: Fri Jul 7 14:36:19 2017 -0600

    Fix cinder::quota_set requires

    The quota set exec was using a non-existant anchor. This change updates
    it to use the cinder::install::end anchor instead.

    Change-Id: Ic9a2299416e7494918835428ba1e1ef311a5de2a
    Closes-Bug: #1702964

Changed in puppet-cinder:
status: In Progress → Fix Released
zhongshengping (chdzsp)
Changed in puppet-nova:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-swift:
assignee: nobody → zhongshengping (chdzsp)
Changed in puppet-openstacklib:
assignee: nobody → zhongshengping (chdzsp)
zhongshengping (chdzsp)
Changed in puppet-designate:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → Medium
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-designate (master)

Fix proposed to branch: master
Review: https://review.openstack.org/482003

Changed in puppet-designate:
status: New → In Progress
zhongshengping (chdzsp)
Changed in puppet-ironic:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → Medium
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ironic (master)

Fix proposed to branch: master
Review: https://review.openstack.org/482051

Changed in puppet-ironic:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-keystone (master)

Reviewed: https://review.openstack.org/481759
Committed: https://git.openstack.org/cgit/openstack/puppet-keystone/commit/?id=b479685940e27dea5fa86155e3a2ba6878865abc
Submitter: Jenkins
Branch: master

commit b479685940e27dea5fa86155e3a2ba6878865abc
Author: Alex Schultz <email address hidden>
Date: Fri Jul 7 15:04:35 2017 -0600

    Fix resource references for latest puppet

    In keystone we had some references to Execs that may or may not have been
    defined depending on the class parameters. The latest version of puppet
    has changed how the catalog is compiled exposing these possibly
    undefined references. This change updates to use resource collectors
    where applicable.

    Change-Id: Id5dcc42301b622e7f8331b0d61fdef8b7fea1992
    Closes-Bug: #1702964

Changed in puppet-keystone:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-ironic (master)

Reviewed: https://review.openstack.org/482051
Committed: https://git.openstack.org/cgit/openstack/puppet-ironic/commit/?id=90b78634df653eb3f7ab095ed1b3ef30297e4088
Submitter: Jenkins
Branch: master

commit 90b78634df653eb3f7ab095ed1b3ef30297e4088
Author: ZhongShengping <chdzsp@163.com>
Date: Mon Jul 10 16:35:47 2017 +0800

    Fix dependency references

    The latest version of puppet now reports these as catalog failures so
    this change removes the unnecessary Package and Service references
    since those are already handled by ironic::deps and fixes the invalid
    anchor reference.

    Change-Id: I3ef0165c844c36d72f8b1042ac7d482ac4209667
    Closes-Bug: #1702964

Changed in puppet-ironic:
status: In Progress → Fix Released
zhongshengping (chdzsp)
Changed in puppet-openstacklib:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-neutron (master)

Reviewed: https://review.openstack.org/481767
Committed: https://git.openstack.org/cgit/openstack/puppet-neutron/commit/?id=f92390204f0b9dac6e14dbef439e318089cbef4d
Submitter: Jenkins
Branch: master

commit f92390204f0b9dac6e14dbef439e318089cbef4d
Author: Alex Schultz <email address hidden>
Date: Fri Jul 7 15:53:46 2017 -0600

    Update resource references for dependencies

    Newer versions of puppet are throwing catalog failures for resources
    that are not being included in the testing. In this case, the references
    should be updated to use our anchors from the neutron::deps class which
    resolves the failures under the latest version of puppet.

    Change-Id: I7ac3c90eb18118f90f0b92dabd3323a6575dac4c
    Closes-Bug: #1702964

Changed in puppet-neutron:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-designate (master)

Reviewed: https://review.openstack.org/482003
Committed: https://git.openstack.org/cgit/openstack/puppet-designate/commit/?id=4ab3a326e9bf82a56caa0ef66ac259d4da1236fe
Submitter: Jenkins
Branch: master

commit 4ab3a326e9bf82a56caa0ef66ac259d4da1236fe
Author: ZhongShengping <chdzsp@163.com>
Date: Mon Jul 10 13:39:56 2017 +0800

    Fix dependency references

    The latest version of puppet now reports these as catalog failures so
    this change removes the unnecessary Package and Service references
    since those are already handled by designate::deps.

    Change-Id: I3e4d1ab3d8efe3bfd0755c4f2524a2fe193a0896
    Closes-Bug: #1702964

Changed in puppet-designate:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-manila (master)

Reviewed: https://review.openstack.org/481761
Committed: https://git.openstack.org/cgit/openstack/puppet-manila/commit/?id=a981c38c160362ab7f1079e8e08c2dbe2b1e90ca
Submitter: Jenkins
Branch: master

commit a981c38c160362ab7f1079e8e08c2dbe2b1e90ca
Author: Alex Schultz <email address hidden>
Date: Fri Jul 7 15:20:47 2017 -0600

    Fix dependency references

    With the deps migration, we left some of the dependency references in
    place which was previously ignored by puppet unit tests. The latest
    version of puppet now reports these as catalog failures so this change
    removes the unnecessary Package and Service references since those are
    already handled by manila::deps and fixes the invalid anchor reference
    for the manila::type and manila::type_set resources.

    Change-Id: Ie4dc0ae559e8f9bc9657fa6ed8ecf53ccda7852d
    Closes-Bug: #1702964

Changed in puppet-manila:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-tripleo (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483500

Changed in tripleo:
assignee: nobody → Emilien Macchi (emilienm)
status: Triaged → In Progress
Changed in puppet-openstacklib:
status: In Progress → Fix Released
zhongshengping (chdzsp)
Changed in puppet-mistral:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-mistral (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483731

Changed in puppet-mistral:
status: New → In Progress
zhongshengping (chdzsp)
Changed in puppet-aodh:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-aodh (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483735

Changed in puppet-aodh:
status: New → In Progress
zhongshengping (chdzsp)
Changed in puppet-barbican:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-barbican (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483737

Changed in puppet-barbican:
status: New → In Progress
zhongshengping (chdzsp)
Changed in puppet-ceilometer:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ceilometer (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483738

Changed in puppet-ceilometer:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-cinder (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483739

zhongshengping (chdzsp)
Changed in puppet-glance:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-glance (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483742

Changed in puppet-glance:
status: New → In Progress
zhongshengping (chdzsp)
Changed in puppet-gnocchi:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-gnocchi (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483744

Changed in puppet-gnocchi:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-ironic (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483753

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-neutron (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483756

zhongshengping (chdzsp)
Changed in puppet-vitrage:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-vitrage (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483760

Changed in puppet-vitrage:
status: New → In Progress
zhongshengping (chdzsp)
Changed in puppet-panko:
assignee: nobody → zhongshengping (chdzsp)
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-panko (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483764

Changed in puppet-panko:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-cinder (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483739

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-mistral (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483731

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-aodh (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483735

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-barbican (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483737

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-ceilometer (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483738

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-gnocchi (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483744

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-ironic (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483753

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-neutron (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483756

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-vitrage (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483760

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-panko (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483764

zhongshengping (chdzsp)
Changed in puppet-aodh:
status: In Progress → Fix Released
Changed in puppet-barbican:
status: In Progress → Fix Released
Changed in puppet-ceilometer:
status: In Progress → Fix Released
Changed in puppet-glance:
status: In Progress → Fix Committed
Changed in puppet-gnocchi:
status: In Progress → Fix Released
Changed in puppet-glance:
status: Fix Committed → Fix Released
Changed in puppet-panko:
status: In Progress → Fix Released
Changed in puppet-vitrage:
status: In Progress → Fix Released
Changed in puppet-mistral:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-swift (master)

Fix proposed to branch: master
Review: https://review.openstack.org/483855

Changed in puppet-swift:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-tripleo (master)

Reviewed: https://review.openstack.org/483500
Committed: https://git.openstack.org/cgit/openstack/puppet-tripleo/commit/?id=3ee568800d9295bc2a4f843bd3ce74b109613c6b
Submitter: Jenkins
Branch: master

commit 3ee568800d9295bc2a4f843bd3ce74b109613c6b
Author: Emilien Macchi <email address hidden>
Date: Thu Jul 13 11:26:54 2017 -0700

    Update resource references for dependencies

    The latest version of puppet now reports these as catalog failures so
    this change removes the unnecessary references and the references
    should be updated.

    Closes-Bug: #1702964
    Change-Id: Iebc547aa92f9f40e4a633c57d79e6c9cddb5dd28

Changed in tripleo:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-cinder 11.2.0

This issue was fixed in the openstack/puppet-cinder 11.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-designate 11.2.0

This issue was fixed in the openstack/puppet-designate 11.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-ironic 11.2.0

This issue was fixed in the openstack/puppet-ironic 11.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-keystone 11.2.0

This issue was fixed in the openstack/puppet-keystone 11.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-manila 11.2.0

This issue was fixed in the openstack/puppet-manila 11.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-neutron 11.2.0

This issue was fixed in the openstack/puppet-neutron 11.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-openstacklib 11.2.0

This issue was fixed in the openstack/puppet-openstacklib 11.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-tripleo 7.2.0

This issue was fixed in the openstack/puppet-tripleo 7.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on puppet-swift (master)

Change abandoned by zhongshengping (chdzsp@163.com) on branch: master
Review: https://review.openstack.org/483855

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-nova (master)

Fix proposed to branch: master
Review: https://review.openstack.org/489725

Changed in puppet-nova:
assignee: zhongshengping (chdzsp) → Alex Schultz (alex-schultz)
status: Confirmed → In Progress
Changed in puppet-swift:
assignee: zhongshengping (chdzsp) → Alex Schultz (alex-schultz)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-nova (master)

Reviewed: https://review.openstack.org/489725
Committed: https://git.openstack.org/cgit/openstack/puppet-nova/commit/?id=ca1bdcfd7bf2888f4d7bfc57508079f96b9fb8d5
Submitter: Jenkins
Branch: master

commit ca1bdcfd7bf2888f4d7bfc57508079f96b9fb8d5
Author: Alex Schultz <email address hidden>
Date: Tue Aug 1 13:45:30 2017 -0600

    Fix resources for latest puppet

    Running the unit tests under the latest puppet fails because of
    undefined resources. This change updates the references to use
    collectors if they are optional or change the definitions in the files
    for resources that are defined in the existing class.

    Change-Id: Ic91a8d577675fd1f2fb21543320426bfe49b1a2e
    Closes-Bug: #1702964

Changed in puppet-nova:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-swift (master)

Reviewed: https://review.openstack.org/483855
Committed: https://git.openstack.org/cgit/openstack/puppet-swift/commit/?id=8686642562ea86cd2f1457ab332ecaad02088130
Submitter: Jenkins
Branch: master

commit 8686642562ea86cd2f1457ab332ecaad02088130
Author: ZhongShengping <chdzsp@163.com>
Date: Fri Jul 14 15:47:52 2017 +0800

    Update resource references for dependencies

    The latest version of puppet now reports these as catalog failures so
    this change removes the unnecessary references and the references
    should be updated.

    Change-Id: I2001f8bb91ff70cf100140c7861606db459c2ad9
    Closes-Bug: #1702964
    Co-Authored-By: Alex Schultz <email address hidden>

Changed in puppet-swift:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to puppet-nova (master)

Fix proposed to branch: master
Review: https://review.openstack.org/490260

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to puppet-nova (master)

Reviewed: https://review.openstack.org/490260
Committed: https://git.openstack.org/cgit/openstack/puppet-nova/commit/?id=08661e0fef8e22176a44bf250e20b43c220db531
Submitter: Jenkins
Branch: master

commit 08661e0fef8e22176a44bf250e20b43c220db531
Author: ZhongShengping <chdzsp@163.com>
Date: Thu Aug 3 08:48:54 2017 +0800

    Fix resources for latest puppet

    Running the unit tests under the latest puppet fails because of
    undefined resources. This change updates the references to use
    collectors if they are optional or change the definitions in the files
    for resources that are defined in the existing class.

    Change-Id: I5506a563c459baf9d34246a1d517e07a82e0f36b
    Closes-Bug: #1702964

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-ceph 2.4.0

This issue was fixed in the openstack/puppet-ceph 2.4.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-nova 11.3.0

This issue was fixed in the openstack/puppet-nova 11.3.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/puppet-swift 11.3.0

This issue was fixed in the openstack/puppet-swift 11.3.0 release.

zhongshengping (chdzsp)
Changed in puppet-aodh:
assignee: zhongshengping (chdzsp) → nobody
assignee: nobody → zhongshengping (chdzsp)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers