compute_manager is removed, we should stop using it

Bug #1674375 reported by Emilien Macchi on 2017-03-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Nikita Karpin
Packstack
High
Emilien Macchi
puppet-nova
High
Emilien Macchi
tripleo
High
Unassigned

Bug Description

https://github.com/openstack/nova/commit/d9a7c16c305cd7016195cada883867411d3a5eb9

compute_manager is removed, we should stop using it everywhere in puppet-nova, fuel, tripleo, packstack, etc.

Changed in puppet-nova:
assignee: nobody → Emilien Macchi (emilienm)
importance: Undecided → High
status: New → Triaged
summary: - compute_manager is deprecated, we should stop using it
+ compute_manager is removed, we should stop using it
description: updated
Changed in tripleo:
status: New → In Progress
milestone: none → pike-1
assignee: nobody → Emilien Macchi (emilienm)
importance: Undecided → High
Changed in puppet-nova:
status: Triaged → In Progress
Changed in packstack:
status: New → In Progress
assignee: nobody → Emilien Macchi (emilienm)
Nikita Karpin (mkarpin) on 2017-03-20
Changed in fuel:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Nikita Karpin (mkarpin)
milestone: none → 11.0

Fix proposed to branch: master
Review: https://review.openstack.org/447561

Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/447561
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=c25dbe92487225e1209734ecaba2ff93aec42320
Submitter: Jenkins
Branch: master

commit c25dbe92487225e1209734ecaba2ff93aec42320
Author: Mykyta Karpin <email address hidden>
Date: Mon Mar 20 17:51:00 2017 +0200

    Fix nova deprecated parameters

    Upstream patch https://review.openstack.org/447533 removes
    deprecated parameters from puppet-nova, so we need update
    them in fuel-library

    Change-Id: I1c5c2d86e5ac100c2635cae8ee3506d8719d56f9
    Closes-Bug: #1674375

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/447535
Committed: https://git.openstack.org/cgit/openstack/packstack/commit/?id=88200b5f7592336fbb3d9d6213a7175a92643f0d
Submitter: Jenkins
Branch: master

commit 88200b5f7592336fbb3d9d6213a7175a92643f0d
Author: Emilien Macchi <email address hidden>
Date: Mon Mar 20 11:03:18 2017 -0400

    Remove nova compute manager option

    The option was removed in Nova:
    https://github.com/openstack/nova/commit/d9a7c16c305cd7016195cada883867411d3a5eb9

    The option had no effect and we don't need it anymore, therefore we're
    removing it everywhere.

    Change-Id: I079e239aa7ea8a1e849cd95f4297878e1b70f87b
    Related-Bug: #1674375

Reviewed: https://review.openstack.org/447533
Committed: https://git.openstack.org/cgit/openstack/puppet-nova/commit/?id=1063de82f6ba7dfaadc25abd4c0feebcd8b4a0ff
Submitter: Jenkins
Branch: master

commit 1063de82f6ba7dfaadc25abd4c0feebcd8b4a0ff
Author: Emilien Macchi <email address hidden>
Date: Mon Mar 20 10:57:08 2017 -0400

    compute: remove deprecated options

    Remove deprecated compute options:

    - default_availability_zone
    - default_schedule_zone
    - internal_service_availability_zone
    - compute_manager

    Change-Id: Ie5dd8499eaa6770cfc11a86c7b8380c8217d3b68
    Related-Bug: #1674375

Change abandoned by Emilien Macchi (<email address hidden>) on branch: master
Review: https://review.openstack.org/447531

Reviewed: https://review.openstack.org/447531
Committed: https://git.openstack.org/cgit/openstack/instack-undercloud/commit/?id=b8789f1db3942437aef13e35d00b42ff85c7eaee
Submitter: Jenkins
Branch: master

commit b8789f1db3942437aef13e35d00b42ff85c7eaee
Author: Emilien Macchi <email address hidden>
Date: Mon Mar 20 10:50:31 2017 -0400

    Remove compute_manager, deprecated in Nova

    compute_manager option has been deprecated in Nova:
    https://github.com/openstack/nova/commit/d9a7c16c305cd7016195cada883867411d3a5eb9

    And is not needed with:
    https://github.com/openstack/nova/commit/6047d790a32ef5a65d4d6b029f673ce53c3d4141

    Let's clean nova.conf and remove the useless option.

    Change-Id: Ia3ec20998db71b799874d3aaf9daa3df3ff78e3b
    Related-Bug: #1674375

Changed in tripleo:
milestone: pike-1 → pike-2
Changed in tripleo:
milestone: pike-2 → pike-3
Emilien Macchi (emilienm) wrote :

There are no currently open reviews on this bug, changing the status back to the previous state and unassigning. If there are active reviews related to this bug, please include links in comments.

Changed in tripleo:
status: In Progress → New
assignee: Emilien Macchi (emilienm) → nobody
Changed in tripleo:
status: New → Triaged
Changed in tripleo:
milestone: pike-3 → pike-rc1
Ben Nemec (bnemec) wrote :

It looks like this was fixed in TripleO. Feel free to reopen if I'm mistaken.

Changed in tripleo:
status: Triaged → Fix Released
Javier Peña (jpena-c) wrote :
Changed in packstack:
status: In Progress → Fix Released
importance: Undecided → High
Changed in puppet-nova:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers