'glance' option for packages_service is deprecated in murano

Bug #1630209 reported by Kirill Zaitsev on 2016-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Denis Egorenko
fuel-plugin-murano
Medium
Denis Egorenko
puppet-murano
Medium
Denis Egorenko

Bug Description

'glance' option for packages_service has been deprecated in favor of 'glare', since 'glare' is now a separate openstack project and is not directly related to glance anymore

Changed in puppet-murano:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Denis Egorenko (degorenko)
Changed in fuel:
status: New → Confirmed
importance: Undecided → Medium

Fix proposed to branch: master
Review: https://review.openstack.org/381749

Changed in puppet-murano:
status: Confirmed → In Progress
Changed in fuel-plugin-murano:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Denis Egorenko (degorenko)
milestone: none → 1.1.1

Fix proposed to branch: master
Review: https://review.openstack.org/381763

Changed in fuel:
assignee: nobody → Denis Egorenko (degorenko)
status: Confirmed → In Progress
Changed in fuel-plugin-murano:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/381749
Committed: https://git.openstack.org/cgit/openstack/puppet-murano/commit/?id=f28bdd2d12990ace6cb31527769d1a5fe4a609ab
Submitter: Jenkins
Branch: master

commit f28bdd2d12990ace6cb31527769d1a5fe4a609ab
Author: Denis Egorenko <email address hidden>
Date: Tue Oct 4 15:20:45 2016 +0300

    Change section for setting package_service backend

    Now Murano has switched using package_service option from package_opts
    section to new engine section. Hence we need to update puppets too.

    Change-Id: I20ad24b47b16287a385ce54d90bae18ddb4c7402
    Closes-bug: #1630209

Changed in puppet-murano:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/381971
Committed: https://git.openstack.org/cgit/openstack/puppet-murano/commit/?id=9abc63983d0ac9a0a73e6fe2678903b65870d77e
Submitter: Jenkins
Branch: stable/newton

commit 9abc63983d0ac9a0a73e6fe2678903b65870d77e
Author: Denis Egorenko <email address hidden>
Date: Tue Oct 4 15:20:45 2016 +0300

    Change section for setting package_service backend

    Now Murano has switched using package_service option from package_opts
    section to new engine section. Hence we need to update puppets too.

    Change-Id: I20ad24b47b16287a385ce54d90bae18ddb4c7402
    Closes-bug: #1630209
    (cherry picked from commit f28bdd2d12990ace6cb31527769d1a5fe4a609ab)

tags: added: in-stable-newton
Changed in fuel:
assignee: Denis Egorenko (degorenko) → Maksim Malchuk (mmalchuk)
Changed in fuel:
assignee: Maksim Malchuk (mmalchuk) → Denis Egorenko (degorenko)
milestone: none → 10.0
Changed in fuel-plugin-murano:
importance: High → Medium

Reviewed: https://review.openstack.org/381763
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=fdf6cd5ea17e2328f9215484a475052ebc4a471c
Submitter: Jenkins
Branch: master

commit fdf6cd5ea17e2328f9215484a475052ebc4a471c
Author: Denis Egorenko <email address hidden>
Date: Tue Oct 4 15:28:52 2016 +0300

    Set Murano package_service backend as glare

    Murano option package_service now should be set to 'glare' because 'glance'
    is deprecated and will not be used in future.

    Change-Id: I73f6053710c64f7e34905a2ced984d3b47c7337a
    Closes-bug: #1630209

Changed in fuel:
status: In Progress → Fix Committed

This issue was fixed in the openstack/puppet-murano 10.0.0 release.

Denis Egorenko (degorenko) wrote :
Changed in fuel-plugin-murano:
status: In Progress → Fix Committed
Alex Kholkin (akholkin) on 2016-11-25
Changed in fuel-plugin-murano:
status: Fix Committed → Fix Released

This issue was fixed in the openstack/puppet-murano 9.5.0 release.

This issue was fixed in the openstack/fuel-library 11.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers